ReSharper ignores additional include directories in Makefile projects (VS2015)

I found a problem with Makefile projects. In these projects, ReSharper C++ 1.1 doesn't seem to pick up the additional include directories" specified in the "VC++ Directories" property sheet. I'm running VS2015 Community edition on Windows 8.1 64-bit.

I'm attaching a ZIP file with two VS2015 solutions that have identical structure:
* In TestMSBuild the project is a regular C++ console project, and there the ReSharper intellisense works correctly, and the additional include directories are respected.
* In TestMakefile the project is a Makefile project, and the ReSharper intellisense breaks, even though the include directory is specified.

Is this a bug or am I missing something?

By the way, I think I also found another nasty bug in VS2015 with Makefile projects. In the attached TestMakefile example, if you delete the .vs directory (where the .suo file resides) and then open the solution, the property sheet of the project is not a Makefile property sheet anymore but that of a regular VC++ project. It's messed up and I can't find a way to fix it. Any ideas?

Thanks very much in advance!

Edit: I managed to fix the Makefile project propetry sheet glitch by manually setting the "Configuration Type" project property to "Makefile". Once this is done and the project saved, then the .vs dir can be deleted and the property sheet is always the Makefile one. However, I couldn't find a solution to ReSharper not picking up the include directories from the "VC++ Directories -> Include Directories" project property :( Any ideas?

Edit2: I updated the attached repro .zip file. Now there's just one VS2015 solution with two projects -- one regular VC++ and one Makefile. Both projects use the same source tree and have the same VC++ include directories set. But ReSharper works correctly only with the VC++ project. It can't find the included header file in the Makefile project.

Edit3: I can confirm the problem also occurs on a clean Windows 10 machine with only VS2015 and ReSharper C++ 1.1 installed.


I am using VS2015 with some Linux cross development work. I have not been able to get RS C++ to work, so I added
a hotkey to toggle ReSharper on and off, and I turn it off for C++ development. It's not optimal, but at le
ast I can work.


Hello Iliyan!
Thank you for contacting us.
Sorry for delay with answer.
Unfortunately, I can't reproduce your problem. Could you please try out ReSharper EAP builds from here: to see is the issue still relevant?
Thank you!



I can't test right now, but I think the reason why you can't reproduce the issue is that it's been fixed already:

Which is great :)



please feel free to contact us in case of any questions or problems.
Thank you!


Please sign in to leave a comment.