Switch between Header Files and Source doesn't work

In the documentation it states that you can use Visual Studio Pro 2015 and C++ Resharper and use Alt + O to switch between header and source files. I cannot seem to get this to work at all. The only thing that happens in a little ding.

Ctrl + Shift + G also just says "Navigate to in explorer"

16 comments
Comment actions Permalink

Hello!
Thank you for contacting us!
One of the reasons of your problems could be that you use managed C++ in your project, and we, unfortunately, don't support managed C++ now.
Thank you!

0
Comment actions Permalink

So my interpretation of this was that I can press ALT + O anywhere in the editor to switch between files. But this is incorrect. I have to click on Resharper -> Navigate To -> Switch files. which is a pain because it requires me to grab the mouse.

0
Comment actions Permalink

'Switch Header/Source' should work as you've described. Could it be that keyboard mapping got somehow mangled in your VS instance? When you invoke the 'Navigate To' context menu, does it show the keybinding next to the 'Switch Header/Source' item? Can you please check that 'Alt+O' is bound to 'EditorContextMenus.CodeWindow.Navigate.ReSharper_SwitchHeaderSource' in Tools->Options->Environment->Keyboard? Applying the R# keyboard scheme again via 'ReSharper->Options->Environment->Keyboard & Mouse->Apply Scheme' might fix the keyboard layout.

0
Comment actions Permalink

Same problem here also.

Followed the instructions and still getting the error sound when pressing ALT+O

0
Comment actions Permalink

Solved by using a different key combination....Looks like even after removing previous binding, ALT-O is reserved for something else.

ALT-H work.s

0
Comment actions Permalink

David,

Could you please check what Alt+O is bound to now in your keyboard layout?

Thanks!

0
Comment actions Permalink

Same problem here.
I've checked the bonding:

"'EditorContextMenus.CodeWindow.Navigate.ReSharper_SwitchHeaderSource' in Tools->Options->Environment->Keyboard? Applying the R# keyboard scheme again via 'ReSharper->Options->Environment->Keyboard & Mouse->Apply Scheme' might fix the keyboard layout."

Everything looks fine.  When I press "Alt+O" still nothing happens.

0
Comment actions Permalink

Stefan,

Where are the files that ReSharper should switch between are located, physically and in terms of project structure? Are they both included into the solution?

Thanks!

0
Comment actions Permalink

January 2019, I'm still having this problem.  In my case it seems 'EditorContextMenus.CodeWindow.Navigate.ReSharper_SwitchHeaderSource' doens't even appear as a command:

0
Comment actions Permalink

The command's name is "ReSharper.ReSharper_SwitchHeaderSource". Could you please check whether it's bound to a shortcut?

0
Comment actions Permalink

@Igor - still nothing...

0
Comment actions Permalink

That's strange. What R++ version are you using? Are the rest of the features working? Could you try reinstalling R++ and checking if it helps?

0
Comment actions Permalink

I'm using 2018.2.3, and I can't upgrade because of a blocking issue that i reported, that has to with unit tests (not related).   Perhaps in the downgrade process something went wrong, I will try to uninstall.

0
Comment actions Permalink

Re-install made the command appear, and manually binding it now works. Thanks a lot!

0
Comment actions Permalink

Great! What's the issue that prevents you from upgrading specifically, maybe I can nudge somebody? I can't find anything recent in YouTrack.

0

Please sign in to leave a comment.