Resharper - how to disable indexing for the project in the solution

Answered

The solution has a number of projects, among which one is auxiliary. It contains a hierarchy of classes, in which entries are stored localization constant. These files are large enough. The problem is that when I use navigation of ReSharper "GoTo Everything/Type": list is almost completely filled with the elements of this project. As a result, find the item you want is very difficult.

As I understand it, if ReSharper not will index the files, then, in principle, they will not display in ReSharper. How to disable indexing ReSharper specific project in the solution? But if there is another option: it would be great :)

3 comments
Comment actions Permalink
Official comment

Hello Oleg,

In ReSharper 10.1 EAP, "Elements to skip" list has been added to "ReSharper | Options | Environment | Search & Navigation" page. So now you may exclude any files/folders (e.g. project folder) from search and navigation features.

Thanks! 

Comment actions Permalink

Thank you very much! That solved my problem!

0
Comment actions Permalink

Hello, is there any way to skip all folder within some folder from being shown in resharper navigation (when pressing Ctrl + T). Problem is that if I specified folder e.g. node_modules under "Search and Navigation" -> "Elements to skip" than node_modules and files within it (any deep) stops appearing in search but other folders still appears (e.g. lodash etc.). I think it is some kind of a bug because webstorm acts like it suppose to act - if you exclude node_modules all folders within parent ire excluded.
Or there is some another way to achieve this (like wildcard)? (I do not want to specify all folders manually)

1

Please sign in to leave a comment.