6 comments
Comment actions Permalink

Hello Mark,

ReSharper should not take underscores in method names into account. Could
you please attach a small sample demonstrating this problem? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi,

Is there a way to prevent Resharper from hinting that my method needs
to be renamed when I have underscores?  I'm using Respharer 5.1.  I'm
refererring to a discussion that there was an option to do that on
previous versions of Resharper (/message/5237681#5237681).

Thanks!

---
Original message URL:
http://devnet.jetbrains.net/message/5274219#5274219



0
Comment actions Permalink

Hi Andrey,

Here's the print screen.

This_Method_Is_Ok.png

0
Comment actions Permalink

Hello,

Please open ReSharper | Options | Languages | Common | Naming Style, press
'Advanced...' and change 'Event subscrption on fields:' from '$object$_On$event$'
to '$object$_$event$'. Let me know if this helps. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi Andrey,

Here's the print screen.

Image:This_Method_Is_Ok.png

---
Original message URL:
http://devnet.jetbrains.net/message/5274322#5274322



0
Comment actions Permalink

Since this problem has been reported by lots of people, and the fix is
always the same, can you change the default in the next release (5.2 and
6.0)?


"Andrew Serebryansky" <andrew.serebryansky@jetbrains.com> wrote in message
news:c8a898dda3878cd37685a1f38ef@news.intellij.net...

Hello,

>

Please open ReSharper | Options | Languages | Common | Naming Style, press
'Advanced...' and change 'Event subscrption on fields:' from
'$object$_On$event$' to '$object$_$event$'. Let me know if this helps.
Thank you!

>

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> Hi Andrey,
>>
>> Here's the print screen.
>>
>> Image:This_Method_Is_Ok.png
>>
>> ---
>> Original message URL:
>> http://devnet.jetbrains.net/message/5274322#5274322
>

0
Comment actions Permalink

Hello Paul,

Sure, we will consider that. However, please note that this could possibly
affect an unknown number of users who use the current default settings. Thank
you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Since this problem has been reported by lots of people, and the fix is
always the same, can you change the default in the next release (5.2
and 6.0)?

"Andrew Serebryansky" <andrew.serebryansky@jetbrains.com> wrote in
message news:c8a898dda3878cd37685a1f38ef@news.intellij.net...

>> Hello,
>>
>> Please open ReSharper | Options | Languages | Common | Naming Style,
>> press 'Advanced...' and change 'Event subscrption on fields:' from
>> '$object$_On$event$' to '$object$_$event$'. Let me know if this
>> helps. Thank you!
>>
>> Andrey Serebryansky
>> Senior Support Engineer
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Hi Andrey,
>>>
>>> Here's the print screen.
>>>
>>> Image:This_Method_Is_Ok.png
>>>
>>> ---
>>> Original message URL:
>>> http://devnet.jetbrains.net/message/5274322#5274322


0
Comment actions Permalink

True, but I'm not sure why anyone would be using the current default
setting.

When you're coding, and you double-click on a control, Microsoft GENERATES
the names of those methods for you.  I haven't hand-coded a name like that
in ages.  It seems the ReSharper default should match the VisualStudio
default, and that that would cover 80% of the cases at least.  It would
certainly cover 100% of mine.


"Andrew Serebryansky" <andrew.serebryansky@jetbrains.com> wrote in message
news:c8a898dda4378cd38e6d27ab2c4@news.intellij.net...

Hello Paul,

>

Sure, we will consider that. However, please note that this could possibly
affect an unknown number of users who use the current default settings.
Thank you!

>

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> Since this problem has been reported by lots of people, and the fix is
>> always the same, can you change the default in the next release (5.2
>> and 6.0)?
>>
>> "Andrew Serebryansky" <andrew.serebryansky@jetbrains.com> wrote in
>> message news:c8a898dda3878cd37685a1f38ef@news.intellij.net...
>>
>>> Hello,
>>>
>>> Please open ReSharper | Options | Languages | Common | Naming Style,
>>> press 'Advanced...' and change 'Event subscrption on fields:' from
>>> '$object$_On$event$' to '$object$_$event$'. Let me know if this
>>> helps. Thank you!
>>>
>>> Andrey Serebryansky
>>> Senior Support Engineer
>>> JetBrains, Inc
>>> http://www.jetbrains.com
>>> "Develop with pleasure!"
>>>> Hi Andrey,
>>>>
>>>> Here's the print screen.
>>>>
>>>> Image:This_Method_Is_Ok.png
>>>>
>>>> ---
>>>> Original message URL:
>>>> http://devnet.jetbrains.net/message/5274322#5274322
>

0

Please sign in to leave a comment.