Can't install build 66

When install gets into the copy phase (just after asking if I want to install it
for me only or for everyone) I get the following error (cut & paste from log
file):

The system cannot open the device or file specified.
The installer has encountered an unexpected error installing this package. This
may indicate a problem with this package. The error code is 2755. The arguments
are: 110, c:\Download\Resharper66.msi,
=== Logging stopped: 2004/02/19 13:57:39 ===

6 comments

Predrag,

if you still cannot install 66, could you please try to uninstall the
previous ReSharper build and try again
(if you haven't yet, of course)?

Thanks,
Dmitry

"Predrag Stanar" <reply.to.usenet@nospam.com> wrote in message
news:a19a30d97ggk7uv8ri76p0fs497l4ukvvk@4ax.com...

When install gets into the copy phase (just after asking if I want to

install it

for me only or for everyone) I get the following error (cut & paste from

log

file):

>

The system cannot open the device or file specified.
The installer has encountered an unexpected error installing this package.

This

may indicate a problem with this package. The error code is 2755. The

arguments

are: 110, c:\Download\Resharper66.msi,
=== Logging stopped: 2004/02/19 13:57:39 ===

>


0


Did you pick to install the add-in 'Just for me' or 'Everyone'? I found
installing build #65 over the top of #64 that I had to pick 'Everyone'
or it failed to install.

Anyway, maybe that's a bug with the installation procedure - IntelliJ?


Regards,
Corey.


Predrag Stanar wrote:

When install gets into the copy phase (just after asking if I want to install it
for me only or for everyone) I get the following error (cut & paste from log
file):

The system cannot open the device or file specified.
The installer has encountered an unexpected error installing this package. This
may indicate a problem with this package. The error code is 2755. The arguments
are: 110, c:\Download\Resharper66.msi,
=== Logging stopped: 2004/02/19 13:57:39 ===

0

Corey Yeatman <corey.yeatman@fifthweb.net> wrote:

>
>Did you pick to install the add-in 'Just for me' or 'Everyone'? I found
>installing build #65 over the top of #64 that I had to pick 'Everyone'
>or it failed to install.
>
>Anyway, maybe that's a bug with the installation procedure - IntelliJ?

I tried both, more than once. I uninstalled previous version. I rebooted, again,
more than once. No matter what I can't install it.

0

Predrag,

we've run MSI validator against build 66 but it found nothing suspicious
that might cause your problem.
We're looking further into this.

"Predrag Stanar" <reply.to.usenet@nospam.com> wrote in message
news:kc5c30h9h440uoi6v0emi8sgaqrl7b76f7@4ax.com...

Corey Yeatman <corey.yeatman@fifthweb.net> wrote:

>

>
>Did you pick to install the add-in 'Just for me' or 'Everyone'? I found
>installing build #65 over the top of #64 that I had to pick 'Everyone'
>or it failed to install.
>
>Anyway, maybe that's a bug with the installation procedure - IntelliJ?

>

I tried both, more than once. I uninstalled previous version. I rebooted,

again,

more than once. No matter what I can't install it.



0

Three builds after, and same error. Well, I couldn't wait any more, so I got
armed with File and Registry monitors and slowly but steadily got to the
conclusion.

I save all my downloads in the directory that's encrypted (using standard XP
encryption functionality). That's the reason why it fails. File monitor shows at
one moment that msiexec.exe is trying to read resharper??.msi and it's getting
"access denied" from NT_SECURITY back (interestingly enough, other read attempts
are just fine). Few milliseconds after that it opens log file and starts writing
error message to it.

When I moved resharper??.msi to the normal, non encrypted, directory
installation worked as expected. In well over a year I have directories
encrypted, ReSharper is first and only package that failed in this way.

So, I'm back in business, evaluating newest bugs ... err .. features in
ReSharper.

"Dmitry Shaporenkov\(JetBrains\)" <dsha@jetbrains.com> wrote:

>Predrag,
>
>we've run MSI validator against build 66 but it found nothing suspicious
>that might cause your problem.
>We're looking further into this.


0

Predrag,

thanks for your investigation. In our turn,
the problem looks mysterious, because the
ReSharper*.msi are built from a standard VS.NET
Setup project, and we don't perform any additional processing of them.
Anyway, we'll try to reproduce it and understand why this can happen.

"Predrag Stanar" <reply.to.usenet@nospam.com> wrote in message
news:ri7v30tb44rhsnidru0u0rbcnvf64k44gm@4ax.com...

Three builds after, and same error. Well, I couldn't wait any more, so I

got

armed with File and Registry monitors and slowly but steadily got to the
conclusion.

>

I save all my downloads in the directory that's encrypted (using standard

XP

encryption functionality). That's the reason why it fails. File monitor

shows at

one moment that msiexec.exe is trying to read resharper??.msi and it's

getting

"access denied" from NT_SECURITY back (interestingly enough, other read

attempts

are just fine). Few milliseconds after that it opens log file and starts

writing

error message to it.

>

When I moved resharper??.msi to the normal, non encrypted, directory
installation worked as expected. In well over a year I have directories
encrypted, ReSharper is first and only package that failed in this way.

>

So, I'm back in business, evaluating newest bugs ... err .. features in
ReSharper.

>

"Dmitry Shaporenkov\(JetBrains\)" <dsha@jetbrains.com> wrote:

>

>Predrag,
>
>we've run MSI validator against build 66 but it found nothing suspicious
>that might cause your problem.
>We're looking further into this.

>
>


0

Please sign in to leave a comment.