Problem installaing version 70

Hi there - I cannot install version 70 of ReSharper.

An exception is printed in the console window of the Registrar.exe.

I already have version 66 installed. I have tried uninstalling version 66
but the uninstaller also fails.

I have tried installing version 70 on another machine that did not have any
versions installed, and here the installation worked just fine.

The exception i get is the same whether or not I try to uninstall version 66
from Add/Remove Programs or try to install version 70 directly.

I have also tried to run RegAsm ReSharper..dll /unregister

The exception is this:

Failed to determine if VS.NET is running. Bailing out. Details:
System.InvalidOperationException: Process performance counter is disabled,
so the requested operation cannot be performed.
at
System.Diagnostics.NtProcessManager.GetProcessInfos(PerformanceCounterLib
library)
at System.Diagnostics.NtProcessManager.GetProcessInfos(string machineName,
boolean isRemoteMachine)
at System.Diagnostics.NtProcessManager.GetProcessInfos(string machineName)
at System.Diagnostics.Process.GetProcessByName(string processName, string
machineName)
at System.Diagnostics.Process.GetProcessByName(string processName)
at Registrar.Main(string[] args)


I haven't modified any "Process performance counters" since my last
installation. I get the error whether or not VS.NET 2003 is running or not.

Regards
Thomas Koch


2 comments
Comment actions Permalink

Thomas,

we've removed check for running VS.NET in Registrar.exe because the way we
did it turned out to be unreliable.
So the problem should disappear in 71 which is likely to be published today.

"Thomas Koch" <thomask_vs@yahoo.dk> wrote in message
news:c249nq$hj5$1@is.intellij.net...

Hi there - I cannot install version 70 of ReSharper.

>

An exception is printed in the console window of the Registrar.exe.

>

I already have version 66 installed. I have tried uninstalling version 66
but the uninstaller also fails.

>

I have tried installing version 70 on another machine that did not have

any

versions installed, and here the installation worked just fine.

>

The exception i get is the same whether or not I try to uninstall version

66

from Add/Remove Programs or try to install version 70 directly.

>

I have also tried to run RegAsm ReSharper..dll /unregister

>

The exception is this:

>

Failed to determine if VS.NET is running. Bailing out. Details:
System.InvalidOperationException: Process performance counter is disabled,
so the requested operation cannot be performed.
at
System.Diagnostics.NtProcessManager.GetProcessInfos(PerformanceCounterLib
library)
at System.Diagnostics.NtProcessManager.GetProcessInfos(string

machineName,

boolean isRemoteMachine)
at System.Diagnostics.NtProcessManager.GetProcessInfos(string

machineName)

at System.Diagnostics.Process.GetProcessByName(string processName,

string

machineName)
at System.Diagnostics.Process.GetProcessByName(string processName)
at Registrar.Main(string[] args)

>
>

I haven't modified any "Process performance counters" since my last
installation. I get the error whether or not VS.NET 2003 is running or

not.
>

Regards
Thomas Koch

>
>


0
Comment actions Permalink

Hi Dmitry,

Today I tried to install build 70 and the assemblies are placed
successfully in the GAC, but I still get an exception.

Here is the output of the .NET debuger:



-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --

'Registrar.exe': Loaded
'c:\windows\microsoft.net\framework\v1.1.4322\mscorlib.dll', No symbols
loaded.
'Registrar.exe': Loaded 'C:\Program
Files\JetBrains\ReSharper\Registrar.exe', No symbols loaded.
'Registrar.exe': Loaded
'c:\windows\assembly\gac\system.windows.forms\1.0.5000.0__b77a5c561934e089\system.windows.forms.dll',
No symbols loaded.
'Registrar.exe': Loaded
'c:\windows\assembly\gac\system.xml\1.0.5000.0__b77a5c561934e089\system.xml.dll',
No symbols loaded.
'Registrar.exe': Loaded
'c:\windows\assembly\gac\envdte\7.0.3300.0__b03f5f7f11d50a3a\envdte.dll',
No symbols loaded.
'Registrar.exe': Loaded
'c:\windows\assembly\gac\system\1.0.5000.0__b77a5c561934e089\system.dll',
No symbols loaded.
'Registrar.exe': Loaded
'c:\windows\assembly\gac\office\7.0.3300.0__b03f5f7f11d50a3a\office.dll',
No symbols loaded.
'Registrar.exe': Loaded 'c:\program
files\jetbrains\resharper\services.dll', Symbols loaded.
An unhandled exception of type 'System.NullReferenceException' occurred
in Registrar.exe

Additional information: Object reference not set to an instance of an
object.

-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --

0

Please sign in to leave a comment.