ReSharper didn't work properly with Enterprise Templates

I'll try to use ReSharper in solution that includes 2 Enterprise Templates
projects. Each one includes a number of code projects. The second even
include a VB.NET project. So now even the basic functionality as 'Rename'
didn't work properly. Did you test this build with Enterprise Templates?

Evgeny Bobrov.


3 comments
Comment actions Permalink

Evgeny,

could you please describe in more details what didn't work properly?

"Evgeny Bobrov" <dr_dest@ukr.net> wrote in message
news:c8vtem$bvl$1@is.intellij.net...

I'll try to use ReSharper in solution that includes 2 Enterprise Templates
projects. Each one includes a number of code projects. The second even
include a VB.NET project. So now even the basic functionality as 'Rename'
didn't work properly. Did you test this build with Enterprise Templates?

>

Evgeny Bobrov.

>
>


0
Comment actions Permalink

Ok. I'll describe you the whole solution structure and what I've observe
when working with ReSharper. So let's start.
This is the structure of the solution:
Solution (eTCM)
- ëÏÄ (this is on russian and this is the Enterprise Template project)
- Domain (C# Class Library)
- Services (C# Class Library)
- Windows (C# Windows Application)
- ðÒÏÅËÔ (this is also on russian and this is the Enterprise Template
project)
- Folder1
- Folder 2
- .............
- 3rd Party (open source code projects)
- Data Loading (C# Console Application)
- Validatore.NET (VB.NET Class Library)
- and 3 other projects on C#

1. The ReSharper doesn't prompt me for the license. Is this normal?
2. The ReSharper "loading assemblies" window that I usually see when I loads
solution is loading very fast. Even blink and that's all. So I think the
ReSharper doesn't recognize the Enterprise Template structure
(project-in-project).
3. As result even the basics doesn't work properly. In Domain project all
classes inherit from one DomainObject but when I try to use Alt-B or
Alt-Ctrl-B they didn't work. Find usages on DomainObject reports 0 (but
actually there a hundreds of methods and classes that use it). For
experiment I'll use 'Rename' on this class ... ReSharper renames only this
class. $(
4. It's works across the projects or not? Or it's really the bug with ETP.

Kind regards,
Evgeny Bobrov.

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> ÓÏÏÂÝÉÌ/ÓÏÏÂÝÉÌÁ ×
ÎÏ×ÏÓÔÑÈ ÓÌÅÄÕÀÝÅÅ: news:c8vtsd$f1s$1@is.intellij.net...

Evgeny,

>

could you please describe in more details what didn't work properly?

>

"Evgeny Bobrov" <dr_dest@ukr.net> wrote in message
news:c8vtem$bvl$1@is.intellij.net...

I'll try to use ReSharper in solution that includes 2 Enterprise

Templates

projects. Each one includes a number of code projects. The second even
include a VB.NET project. So now even the basic functionality as

'Rename'

didn't work properly. Did you test this build with Enterprise Templates?

>

Evgeny Bobrov.

>
>

>
>


0
Comment actions Permalink

Evgeny,

thanks, I've reproduced the bug.
I've submitted a request for it:
http://www.intellij.net/tracker/resharper/viewSCR?publicId=2781.
We'll fix this problem ASAP.

"Evgeny Bobrov" wrote in message news:c927a7$1bp$1@is.intellij.net... ]]>


0

Please sign in to leave a comment.