Resharper forgot the keyboard shortcuts

I left Visual Studio open over the weekend and when I returned Resharper had forgotten all of the keyboard shortcuts.

I have repaired the installation as well as uninstalled and re-installed Resharper, but the keyboard shortcuts are still missing.

Is there any way to get them back without having to set them all again in the VS options?

8 comments
Comment actions Permalink

Hi Adrian,

I hope the loosing of the shortcuts will be fixed soon.

As a temporary workaround, close Visual Studio, go to the
\Documents and settings\\Application Data\JetBrains\Resharper\UserSettings.xml and delete line 1.0.1619.19683 (Of course, version number will differ) Then re-open the studio - and all shortcuts will be available again! -- Eugene Pasynkov Developer JetBrains, Inc http://www.jetbrains.com "Develop with pleasure!" "Adrian Banks" ]]> wrote in message
news:870053.1086619298016.JavaMail.itn@is.intellij.net...

I left Visual Studio open over the weekend and when I returned Resharper

had forgotten all of the keyboard shortcuts.
>

I have repaired the installation as well as uninstalled and re-installed

Resharper, but the keyboard shortcuts are still missing.
>

Is there any way to get them back without having to set them all again in

the VS options?
>


0
Comment actions Permalink

Thanks, that did the trick.

0
Comment actions Permalink

That doesn't work for me...

And about the parameters in a method. I'm getting an overloaded list, both
from ReSharper and (the original) from Visual Studio itself. What to do if I
only want the ReSharper version?

Thanks

"Eugene Pasynkov (JetBrains, Inc.)" <Eugene.Pasynkov@jetbrains.com> wrote in
message news:ca3int$rv1$1@is.intellij.net...

Hi Adrian,

>

I hope the loosing of the shortcuts will be fixed soon.

>

As a temporary workaround, close Visual Studio, go to the
\Documents and settings\<your name>\Application
Data\JetBrains\Resharper\UserSettings.xml
and delete line
<setting name="ShortcutsSetVersion">1.0.1619.19683</setting>
(Of course, version number will differ)

>

Then re-open the studio - and all shortcuts will be available again!

>
>

--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Adrian Banks" <no_mail@jetbrains.com> wrote in message
news:870053.1086619298016.JavaMail.itn@is.intellij.net...

I left Visual Studio open over the weekend and when I returned Resharper

had forgotten all of the keyboard shortcuts.
>

I have repaired the installation as well as uninstalled and re-installed

Resharper, but the keyboard shortcuts are still missing.
>

Is there any way to get them back without having to set them all again

in

the VS options?
>

>
>


0
Comment actions Permalink

I have lost all Resharper shortcuts too.

Your suggestion has worked for me in the past, but not with build 86.

I also tried Resharper | Options in the VS.NET IDE, but this made no difference.

0
Comment actions Permalink

Any other suggestions for getting my shortcuts back? I find shortcuts invaluable.

Can't seem to get them back no matter what I try :-((((

0
Comment actions Permalink

James,

doesn't 'Set Shortcuts' button (ReSharper->Options->General->User Interface)
work for you?

"James Hebben" <no_mail@jetbrains.com> wrote in message
news:30750185.1087333303842.JavaMail.itn@is.intellij.net...

Any other suggestions for getting my shortcuts back? I find shortcuts

invaluable.
>

Can't seem to get them back no matter what I try :-((((



0
Comment actions Permalink

I just realised that I had my Keyboard mapping scheme set to . Duh!!!

I have all my lovely Resharper shortcuts back now. Thanks

0
Comment actions Permalink

There used to be warning about this problem but it somehow got lost.
Restored in build #88.

--
Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

"James Hebben" <no_mail@jetbrains.com> wrote in message
news:18084652.1087372773698.JavaMail.itn@is.intellij.net...

I just realised that I had my Keyboard mapping scheme set to [Default

Settings]. Duh!!!
>

I have all my lovely Resharper shortcuts back now. Thanks



0

Please sign in to leave a comment.