Cannot set keyboard shortcuts

With #88 everytime I start my german localized VS I get the attached message box. But I am not using the default keyboard mapping scheme.

I also had to redefine the missing keyboard shortcuts. RS overrides my own keyboard map on every upgrade. Unfortunatly on the german localized VS there are about 15 shortcuts missing after RS overrides the keyboard map, among them are all the three completion keys :(



Attachment(s):
ReSharper-20040617.jpg
2 comments
Comment actions Permalink

Werner,

it is currently an open issue that the ReSharper is unable to set shortcuts
programmatically in localized versions of VS.NET.

I don't quite understand, however, how does ReSharper manage to override
your shortcuts given the above fact? With what shortcuts
does it override you keyboard map?

As a workaround I propose you to backup *.vsk file where VS.NET stores the
keyboard mapping information. This file path looks like
"\Documents and Settings\<user-name>\Application
Data\Microsoft\VisualStudio\7.1\<scheme-name>.vsk"

Thanks,
Dmitry

"Werner Fleck" <no_mail@jetbrains.com> wrote in message
news:1605283.1087458692983.JavaMail.itn@is.intellij.net...

With #88 everytime I start my german localized VS I get the attached

message box. But I am not using the default keyboard mapping scheme.
>

I also had to redefine the missing keyboard shortcuts. RS overrides my own

keyboard map on every upgrade. Unfortunatly on the german localized VS there
are about 15 shortcuts missing after RS overrides the keyboard map, among
them are all the three completion keys :(


0
Comment actions Permalink

I too don't know how RS manages to override my shortcuts - but it does! Would it be helpful if I sent you the .vsk file with the keyboard map RS generates?

Your workaround: I am actually doing it as you suggest, but with #88 it didn't work because RS overrode my restored keymap with its default map.

0

Please sign in to leave a comment.