Build 89/90 and the Web Forms Designer

With both build 89 and 90 when I try to open an ASPX page I get a error:

The file could not be loaded into the Web Forms designer. Please correct the following error and then try loading it again:

Exception from HRESULT: 0x800700C1.

Make sure all of the classes used in the page are built or referenced in the project. Click Help for more information.

This error is showing up when I just open any web form. Any ideas? I tried the re-reg csproj.dll but that didn't help. Is there something else I need to re-reg?

BTW - proxy settings have never worked for me. I haven't had a chance to try it in build 90 yet since I have to turn ReSharper off to work.

5 comments
Comment actions Permalink

Bryant,

while I have no ideas what exactly happened, I can propose you to repair
your VS.NET installation.
The point is that all ReSharper installers up to 89 contained a problem that
caused unregistration of VS.NET dlls. Current (since 90) ReSharper installer
does not reference any VS.NET COM dlls, and it should not break the IDE.
However, what you're experiencing may be a remain of that problem with old
ReSharper installers.
I understand that repairing VS.NET is a long process, so you can first try
to register the dte.olb type library (the details can be found at
http://www.intellij.net/tracker/resharper/viewSCR?publicId=2462#3312406).

"Bryant Likes" <no_mail@jetbrains.com> wrote in message
news:21137480.1088619652934.JavaMail.itn@is.intellij.net...

With both build 89 and 90 when I try to open an ASPX page I get a error:

>

The file could not be loaded into the Web Forms designer. Please correct

the following error and then try loading it again:
>

Exception from HRESULT: 0x800700C1.

>

Make sure all of the classes used in the page are built or referenced in

the project. Click Help for more information.
>

This error is showing up when I just open any web form. Any ideas? I tried

the re-reg csproj.dll but that didn't help. Is there something else I need
to re-reg?
>

BTW - proxy settings have never worked for me. I haven't had a chance to

try it in build 90 yet since I have to turn ReSharper off to work.


0
Comment actions Permalink

I didn't notice this thread and posted, one with the same problem (http://www.intellij.net/forums/thread.jsp?forum=37&thread=99888&tstart=0&trange=15). Register the COM servers doesn't help, only uninstalling ReSharper, solves the problem.

Daniel Santana

0
Comment actions Permalink

Daniel,

do you mean that uninstalling ReSharper build 90 without any other actions
from you
brings Web Forms Designer back to normal?

Thanks,
Dmitry

"Daniel Santana" <no_mail@jetbrains.com> wrote in message
news:29793611.1088704824010.JavaMail.itn@is.intellij.net...

I didn't notice this thread and posted, one with the same problem

(http://www.intellij.net/forums/thread.jsp?forum=37&thread=99888&tstart=0&tr
ange=15). Register the COM servers doesn't help, only uninstalling
ReSharper, solves the problem.
>

Daniel Santana



0
Comment actions Permalink

No, i can confirm that by disabling ReSharper in the Addin Manager, also solves the problem, but i must restart the visual studio session, so that this takes effect, only making unload in the current session doesn't solve the problem.

Hope you can solve this problem, as i love the ReSharper

Best regards

Daniel

0
Comment actions Permalink

Note: This is fixed in build 94. Thanks!

0

Please sign in to leave a comment.