[Build 211] Blurry text when used with black background

I have VS set to display everything on a black background. Using build
211 my currently selected row of text is always shown with a white
background with very garbled text. As far as I can tell, there is no
entry in the Fonts and Colors option to change the color of the
currently selected row. The attached png demonstrates the problem.

Thanks,
Nate



Attachment(s):
blurry_text.png
8 comments
Comment actions Permalink

I have VS set to display everything on a black background. Using
build 211 my currently selected row of text is always shown with a
white background with very garbled text. As far as I can tell, there
is no entry in the Fonts and Colors option to change the color of the
currently selected row. The attached png demonstrates the problem.


Not sure why on earth you'd want to read text off a black background... ;)
But ignoring that, try this. From the ReSharper menu -

ReSharper --> Options --> Editor --> Highlight current line in the editor

Unchecking the box will turn the yellow highlighting off, which should make
it a bit more readable.


0
Comment actions Permalink

Thanks a ton! Don't know how I missed that option previously.

- Nate


Gerrod Thomas wrote:
>> I have VS set to display everything on a black background. Using
>> build 211 my currently selected row of text is always shown with a
>> white background with very garbled text. As far as I can tell, there
>> is no entry in the Fonts and Colors option to change the color of the
>> currently selected row. The attached png demonstrates the problem.


Not sure why on earth you'd want to read text off a black background...
;) But ignoring that, try this. From the ReSharper menu -

ReSharper --> Options --> Editor --> Highlight current line in the
editor

Unchecking the box will turn the yellow highlighting off, which should
make it a bit more readable.

0
Comment actions Permalink

Hello Nate,

we'll provide an option to choose the color of the current line in the near
future. Unfortunately,
it turns out a bit difficult to use Fonts And Colors for it, so may be we'll
end up with a separate
color configuration dialog.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I have VS set to display everything on a black background. Using
build 211 my currently selected row of text is always shown with a
white background with very garbled text. As far as I can tell, there
is no entry in the Fonts and Colors option to change the color of the
currently selected row. The attached png demonstrates the problem.

Thanks,
Nate



0
Comment actions Permalink

Hello Gerrod,

What's wrong with a black (or dark) background? I have been using a dark
blue background for a long time now and it is much easier on the eyes! Also,
the colour syntax highlighting shows up much clearer when on a darker background.
This is a great feature that I can't use - the other one that I was after
(that I am told won't be done in R#4VS2003 because it's done in VS2005 is
highlighting edited code :( will have to move VS I guess)
Up until very recently the light-bulbs didn't have any transparency but they
seem to be looking much better now!

Ronnie


>> I have VS set to display everything on a black background. Using
>> build 211 my currently selected row of text is always shown with a
>> white background with very garbled text. As far as I can tell, there
>> is no entry in the Fonts and Colors option to change the color of the
>> currently selected row. The attached png demonstrates the problem.
>>

Not sure why on earth you'd want to read text off a black
background... ;) But ignoring that, try this. From the ReSharper menu
-

ReSharper --> Options --> Editor --> Highlight current line in the
editor

Unchecking the box will turn the yellow highlighting off, which should
make it a bit more readable.



0
Comment actions Permalink

Actually, all sorts of studies show that its far worse on the eyes, and more
difficult to read. That's why virtually all systems today use dark text on
light backgrounds. There's a lot of science behind that.

Now, personally, I don't like blindingly white backgrounds, but a soft light
gray background works wonders for my eyes.


"Ronnie Barker" <ronnie@freenet.co.uk> wrote in message
news:b52144123cf28c7ce4d5dad1daa@news.jetbrains.com...

Hello Gerrod,

>

What's wrong with a black (or dark) background? I have been using a dark
blue background for a long time now and it is much easier on the eyes!
Also, the colour syntax highlighting shows up much clearer when on a
darker background.
This is a great feature that I can't use - the other one that I was after
(that I am told won't be done in R#4VS2003 because it's done in VS2005 is
highlighting edited code :( will have to move VS I guess)
Up until very recently the light-bulbs didn't have any transparency but
they seem to be looking much better now!

>

Ronnie

>
>
>>> I have VS set to display everything on a black background. Using
>>> build 211 my currently selected row of text is always shown with a
>>> white background with very garbled text. As far as I can tell, there
>>> is no entry in the Fonts and Colors option to change the color of the
>>> currently selected row. The attached png demonstrates the problem.
>>>
>> Not sure why on earth you'd want to read text off a black
>> background... ;) But ignoring that, try this. From the ReSharper menu
>> -
>>
>> ReSharper --> Options --> Editor --> Highlight current line in the
>> editor
>>
>> Unchecking the box will turn the yellow highlighting off, which should
>> make it a bit more readable.
>>
>



0
Comment actions Permalink

Hello Paul,

As much as I love studies, there are 3 things that I think need to be said
here:
1. Personal choice.
b. I get less headaches when working with dark backgrounds!

Ronnie

Actually, all sorts of studies show that its far worse on the eyes,
and more difficult to read. That's why virtually all systems today
use dark text on light backgrounds. There's a lot of science behind
that.

Now, personally, I don't like blindingly white backgrounds, but a soft
light gray background works wonders for my eyes.

"Ronnie Barker" <ronnie@freenet.co.uk> wrote in message
news:b52144123cf28c7ce4d5dad1daa@news.jetbrains.com...

>> Hello Gerrod,
>>
>> What's wrong with a black (or dark) background? I have been using a
>> dark
>> blue background for a long time now and it is much easier on the
>> eyes!
>> Also, the colour syntax highlighting shows up much clearer when on a
>> darker background.
>> This is a great feature that I can't use - the other one that I was
>> after
>> (that I am told won't be done in R#4VS2003 because it's done in
>> VS2005 is
>> highlighting edited code :( will have to move VS I guess)
>> Up until very recently the light-bulbs didn't have any transparency
>> but
>> they seem to be looking much better now!
>> Ronnie
>>
>>>> I have VS set to display everything on a black background. Using
>>>> build 211 my currently selected row of text is always shown with a
>>>> white background with very garbled text. As far as I can tell,
>>>> there is no entry in the Fonts and Colors option to change the
>>>> color of the currently selected row. The attached png demonstrates
>>>> the problem.
>>>>
>>> Not sure why on earth you'd want to read text off a black
>>> background... ;) But ignoring that, try this. From the ReSharper
>>> menu -
>>>
>>> ReSharper --> Options --> Editor --> Highlight current line in the
>>> editor
>>>
>>> Unchecking the box will turn the yellow highlighting off, which
>>> should make it a bit more readable.
>>>


0
Comment actions Permalink

It's most likely that the reason you get fewer headaches with dark
backgrounds as opposed to light backgrounds is due to your CRT monitor's
refresh settings. I've found this over and over, that people don't seem to
go into their settings and crank up the refresh rate. Most people are
sitting and staring at a "strobe light" at 50-60hz, which is very hard on
the eyes, and even harder when the screen is bright.

I'm very sensitive to flicker, so I can tell just by looking at a screen if
it's at 60hz. Lots of people can't perceive it, but it still causes
eye-strain. When I crank up their screens to 72hz or beyond, they suddnely
say how much better their eyes feel and how it's not as tiring to look at
the screen.

If I were you, I'd go to your settings and make sure your refresh rate is
set to AT LEAST 72hz. I think that'll solve the problem with headaches and
tired eyes for you. And then once that's done, you can move to a light
background with dark text, and your eyes will feel even better. :)


"Ronnie Barker" <ronnie@freenet.co.uk> wrote in message
news:b521441242c98c7ceea1f27f0a6@news.jetbrains.com...

Hello Paul,

>

As much as I love studies, there are 3 things that I think need to be said
here:
1. Personal choice.
b. I get less headaches when working with dark backgrounds!

>

Ronnie

>
>> Actually, all sorts of studies show that its far worse on the eyes,
>> and more difficult to read. That's why virtually all systems today
>> use dark text on light backgrounds. There's a lot of science behind
>> that.
>>
>> Now, personally, I don't like blindingly white backgrounds, but a soft
>> light gray background works wonders for my eyes.
>>
>> "Ronnie Barker" <ronnie@freenet.co.uk> wrote in message
>> news:b52144123cf28c7ce4d5dad1daa@news.jetbrains.com...
>>
>>> Hello Gerrod,
>>>
>>> What's wrong with a black (or dark) background? I have been using a
>>> dark
>>> blue background for a long time now and it is much easier on the
>>> eyes!
>>> Also, the colour syntax highlighting shows up much clearer when on a
>>> darker background.
>>> This is a great feature that I can't use - the other one that I was
>>> after
>>> (that I am told won't be done in R#4VS2003 because it's done in
>>> VS2005 is
>>> highlighting edited code :( will have to move VS I guess)
>>> Up until very recently the light-bulbs didn't have any transparency
>>> but
>>> they seem to be looking much better now!
>>> Ronnie
>>>
>>>>> I have VS set to display everything on a black background. Using
>>>>> build 211 my currently selected row of text is always shown with a
>>>>> white background with very garbled text. As far as I can tell,
>>>>> there is no entry in the Fonts and Colors option to change the
>>>>> color of the currently selected row. The attached png demonstrates
>>>>> the problem.
>>>>>
>>>> Not sure why on earth you'd want to read text off a black
>>>> background... ;) But ignoring that, try this. From the ReSharper
>>>> menu -
>>>>
>>>> ReSharper --> Options --> Editor --> Highlight current line in the
>>>> editor
>>>>
>>>> Unchecking the box will turn the yellow highlighting off, which
>>>> should make it a bit more readable.
>>>>
>



0
Comment actions Permalink

Hello Paul,

Hmm, I'm on a laptop!
But maybe the problem relates to an eye injury I had about ten years ago
- hmm - thanks anyway but I still think I'm going to stick to a dark background
- syntax highlighting just looks soooo vivid that it's a dream!

Ronnie

It's most likely that the reason you get fewer headaches with dark
backgrounds as opposed to light backgrounds is due to your CRT
monitor's refresh settings. I've found this over and over, that
people don't seem to go into their settings and crank up the refresh
rate. Most people are sitting and staring at a "strobe light" at
50-60hz, which is very hard on the eyes, and even harder when the
screen is bright.

I'm very sensitive to flicker, so I can tell just by looking at a
screen if it's at 60hz. Lots of people can't perceive it, but it
still causes eye-strain. When I crank up their screens to 72hz or
beyond, they suddnely say how much better their eyes feel and how it's
not as tiring to look at the screen.

If I were you, I'd go to your settings and make sure your refresh rate
is set to AT LEAST 72hz. I think that'll solve the problem with
headaches and tired eyes for you. And then once that's done, you can
move to a light background with dark text, and your eyes will feel
even better. :)

"Ronnie Barker" <ronnie@freenet.co.uk> wrote in message
news:b521441242c98c7ceea1f27f0a6@news.jetbrains.com...

>> Hello Paul,
>>
>> As much as I love studies, there are 3 things that I think need to be
>> said
>> here:
>> 1. Personal choice.
>> b. I get less headaches when working with dark backgrounds!
>> Ronnie
>>
>>> Actually, all sorts of studies show that its far worse on the eyes,
>>> and more difficult to read. That's why virtually all systems today
>>> use dark text on light backgrounds. There's a lot of science behind
>>> that.
>>>
>>> Now, personally, I don't like blindingly white backgrounds, but a
>>> soft light gray background works wonders for my eyes.
>>>
>>> "Ronnie Barker" <ronnie@freenet.co.uk> wrote in message
>>> news:b52144123cf28c7ce4d5dad1daa@news.jetbrains.com...
>>>
>>>> Hello Gerrod,
>>>>
>>>> What's wrong with a black (or dark) background? I have been using a
>>>> dark
>>>> blue background for a long time now and it is much easier on the
>>>> eyes!
>>>> Also, the colour syntax highlighting shows up much clearer when on
>>>> a
>>>> darker background.
>>>> This is a great feature that I can't use - the other one that I was
>>>> after
>>>> (that I am told won't be done in R#4VS2003 because it's done in
>>>> VS2005 is
>>>> highlighting edited code :( will have to move VS I guess)
>>>> Up until very recently the light-bulbs didn't have any transparency
>>>> but
>>>> they seem to be looking much better now!
>>>> Ronnie
>>>>>> I have VS set to display everything on a black background. Using
>>>>>> build 211 my currently selected row of text is always shown with
>>>>>> a white background with very garbled text. As far as I can tell,
>>>>>> there is no entry in the Fonts and Colors option to change the
>>>>>> color of the currently selected row. The attached png
>>>>>> demonstrates the problem.
>>>>>>
>>>>> Not sure why on earth you'd want to read text off a black
>>>>> background... ;) But ignoring that, try this. From the ReSharper
>>>>> menu -
>>>>>
>>>>> ReSharper --> Options --> Editor --> Highlight current line in the
>>>>> editor
>>>>>
>>>>> Unchecking the box will turn the yellow highlighting off, which
>>>>> should make it a bit more readable.
>>>>>


0

Please sign in to leave a comment.