Confused Intellisense

Hi,

I am getting two sets of intellisense messages appearing whilst working
on a webcontrol which is getting very confusing.

I have disabled the VS intellisense via VS2005, Tools -> Options ->
Text Editor -> C# -> IntelliSense -> uncheck "Show completion list
after a character is typed".

Is there anything else I need to do?

Cheers,

Julian

17 comments
Comment actions Permalink

Does anyone have any suggestions for this dual intellisense problem -
it is driving me mad 8-)

Cheers,

Julian

0
Comment actions Permalink

Hello Julian,

do you mean that you're getting two IntelliSense lists, one from VS, and
another
from ReSharper, when you press '.', despite having disabled the VS option?

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Does anyone have any suggestions for this dual intellisense problem -
it is driving me mad 8-)

Cheers,

Julian



0
Comment actions Permalink

Hi Dmitry,

do you mean that you're getting two IntelliSense lists, one from VS, and
another
from ReSharper, when you press '.', despite having disabled the VS option?


Guess so. Yes.

Cheers,

Julian

0
Comment actions Permalink

Hello Julian,

what kind of files does the problem happen in? Only in webcontrols,
or also in regular C# files?


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi Dmitry,

>> do you mean that you're getting two IntelliSense lists, one from VS,
>> and another from ReSharper, when you press '.', despite having
>> disabled the VS option?
>>

Guess so. Yes.

Cheers,

Julian



0
Comment actions Permalink

Hi Dmitry,

what kind of files does the problem happen in? Only in webcontrols,
or also in regular C# files?


I've only noticed it in a webcontrol so far, but will monitor it a bit
more closely now.

Cheers,

Julian

0
Comment actions Permalink

Do you want to use VS intellisense or ReSharper's one?

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi Dmitry,

>> do you mean that you're getting two IntelliSense lists, one from VS,
>> and another from ReSharper, when you press '.', despite having
>> disabled the VS option?
>>

Guess so. Yes.

Cheers,

Julian



0
Comment actions Permalink

Hi Dmitry,

I have the same problem too but I am in a regular C# file.

Alex

Dmitry Shaporenkov (JetBrains) wrote:

Hello Julian,

what kind of files does the problem happen in? Only in webcontrols,
or also in regular C# files?


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> Hi Dmitry,
>>
>>> do you mean that you're getting two IntelliSense lists, one from VS,
>>> and another from ReSharper, when you press '.', despite having
>>> disabled the VS option?
>>>
>> Guess so. Yes.
>>
>> Cheers,
>>
>> Julian
>>


0
Comment actions Permalink

Hello Alex,

do you mean that you have disabled VS IntelliSense and are still seeing it
in a regular C# file?


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi Dmitry,

I have the same problem too but I am in a regular C# file.

Alex

Dmitry Shaporenkov (JetBrains) wrote:

>> Hello Julian,
>>
>> what kind of files does the problem happen in? Only in webcontrols,
>> or also in regular C# files?
>>
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Hi Dmitry,
>>>
>>>> do you mean that you're getting two IntelliSense lists, one from
>>>> VS, and another from ReSharper, when you press '.', despite having
>>>> disabled the VS option?
>>>>
>>> Guess so. Yes.
>>>
>>> Cheers,
>>>
>>> Julian
>>>


0
Comment actions Permalink

Yes, exactly.

In VS2005, Tools->Options->Text Editor->C#->IntelliSense->Completion List. All
this options are unchecked.

Alex

Dmitry Shaporenkov (JetBrains) wrote:

Hello Alex,

do you mean that you have disabled VS IntelliSense and are still seeing
it in a regular C# file?


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> Hi Dmitry,
>>
>> I have the same problem too but I am in a regular C# file.
>>
>> Alex
>>

0
Comment actions Permalink

Hello Alex,

but if you disable ReSharper (via Tools|Add-In Manager), does you still get
VS IntelliSense while it is disabled? If yes,
then it is probably a bug in VS.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Yes, exactly.

In VS2005, Tools->Options->Text Editor->C#->IntelliSense->Completion
List. All
this options are unchecked.
Alex

Dmitry Shaporenkov (JetBrains) wrote:

>> Hello Alex,
>>
>> do you mean that you have disabled VS IntelliSense and are still
>> seeing it in a regular C# file?
>>
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Hi Dmitry,
>>>
>>> I have the same problem too but I am in a regular C# file.
>>>
>>> Alex
>>>


0
Comment actions Permalink

Indeed it is a VS bug. I've disabled ReSharper and VS still show a list! Argh!

Dmitry Shaporenkov (JetBrains) wrote:

Hello Alex,

but if you disable ReSharper (via Tools|Add-In Manager), does you still
get VS IntelliSense while it is disabled? If yes,
then it is probably a bug in VS.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> Yes, exactly.
>>
>> In VS2005, Tools->Options->Text Editor->C#->IntelliSense->Completion
>> List. All
>> this options are unchecked.
>> Alex
>>
>> Dmitry Shaporenkov (JetBrains) wrote:
>>
>>> Hello Alex,
>>>
>>> do you mean that you have disabled VS IntelliSense and are still
>>> seeing it in a regular C# file?
>>>
>>> Regards,
>>> Dmitry Shaporenkov
>>> JetBrains, Inc
>>> http://www.jetbrains.com
>>> "Develop with pleasure!"
>>>> Hi Dmitry,
>>>>
>>>> I have the same problem too but I am in a regular C# file.
>>>>
>>>> Alex
>>>>


0
Comment actions Permalink

Hello Alex,

Indeed it is a VS bug. I've disabled ReSharper and VS still show a
list! Argh!


Maybe you might try to disable "Options -> Text Editor -> C# -> General ->
Auto list members" as well. This one helped for me.

Best regards,
Martin


0
Comment actions Permalink

Hi Martin,

Tried that already. In fact I've disabled every checkbox in that screen with
no luck.

Alex

Martin Carpella wrote:

Hello Alex,

>> Indeed it is a VS bug. I've disabled ReSharper and VS still show a
>> list! Argh!


Maybe you might try to disable "Options -> Text Editor -> C# -> General
-> Auto list members" as well. This one helped for me.

Best regards,
Martin

0
Comment actions Permalink

Hi Valentin,

Do you want to use VS intellisense or ReSharper's one?


Not fussed really - what are the differences?

Cheers,

Julian

0
Comment actions Permalink

Alex Hung <ahung@xbsolutions.com> writes:

Tried that already. In fact I've disabled every checkbox in that screen
with no luck.


Ok, sorry I couldn't help you. Just noted it because I missed it because
it is not on the IntelliSense page.

Hope you'll find a solution.

Martin

0
Comment actions Permalink

Not fussed really - what are the differences?


Well, then try ReSharper's one. To get rid of Visual Studio's one, go to
Tools > Options > Text Editor > C# and uncheck "Auto list members" and "Parameter
information" checkboxes.

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi Valentin,

>> Do you want to use VS intellisense or ReSharper's one?
>>

Not fussed really - what are the differences?

Cheers,

Julian



0
Comment actions Permalink

Hi Valentin,

Well, then try ReSharper's one. To get rid of Visual Studio's one, go to
Tools > Options > Text Editor > C# and uncheck "Auto list members" and "Parameter
information" checkboxes.


OK, I'll try that.

Cheers,

Julian

0

Please sign in to leave a comment.