Fonts and Colors

I've installed build 215 of Resharper 2.0 with VS 2005 and i keep getting
the following error on VS 2005 startup

"Resharper has failed to retrieve one of its Fonts and Colors entries
('Resharper Current Line').
This is usually an indication that Fonts and Colors entries are corrupt.
Please make sure that Resharper is property installed.
You can also try to run 'devenv.exe /setup' from the command line."

I tried running devenv.exe /setup but that didn't fix it. I can use
resharper just fine. I tried searching the newsgroup but found nothing.

Any ideas.

Thanks

Zeid


5 comments
Comment actions Permalink

Hello Zeid,

I suddenly had that after a few days with 215 - found that deleting all of
the caches (maybe jus the central ones - not sure, did the lot) sorted that
one out!

Ronnie

I've installed build 215 of Resharper 2.0 with VS 2005 and i keep
getting the following error on VS 2005 startup

"Resharper has failed to retrieve one of its Fonts and Colors entries
('Resharper Current Line').
This is usually an indication that Fonts and Colors entries are
corrupt.
Please make sure that Resharper is property installed.
You can also try to run 'devenv.exe /setup' from the command line."
I tried running devenv.exe /setup but that didn't fix it. I can use
resharper just fine. I tried searching the newsgroup but found
nothing.

Any ideas.

Thanks

Zeid



0
Comment actions Permalink

Hello Ronnie,

this error message seemed to happen intermittently and we disabled it. There
is a problem, however, that on VS 2005
ReSharper Fonts and Colors entries sometimes disappear, and 'devenv.exe /setup'
doesn't fix it.
We're investigating this now.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Zeid,

I suddenly had that after a few days with 215 - found that deleting
all of the caches (maybe jus the central ones - not sure, did the lot)
sorted that one out!

Ronnie

>> I've installed build 215 of Resharper 2.0 with VS 2005 and i keep
>> getting the following error on VS 2005 startup
>>
>> "Resharper has failed to retrieve one of its Fonts and Colors entries
>> ('Resharper Current Line').
>> This is usually an indication that Fonts and Colors entries are
>> corrupt.
>> Please make sure that Resharper is property installed.
>> You can also try to run 'devenv.exe /setup' from the command line."
>> I tried running devenv.exe /setup but that didn't fix it. I can use
>> resharper just fine. I tried searching the newsgroup but found
>> nothing.
>> Any ideas.
>>
>> Thanks
>>
>> Zeid
>>


0
Comment actions Permalink

Hello Dmitry,

I believed that this issue was related to Visual Studio 2003. I haven't encountered
this error yet on Visual Studio 2005.

Gabriel Lozano-Morán
MCSD .NET
Real Software
http://www.realsoftware.be
http://www.realdn.net

Hello Ronnie,

this error message seemed to happen intermittently and we disabled it.
There
is a problem, however, that on VS 2005
ReSharper Fonts and Colors entries sometimes disappear, and
'devenv.exe /setup'
doesn't fix it.
We're investigating this now.
Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> Hello Zeid,
>>
>> I suddenly had that after a few days with 215 - found that deleting
>> all of the caches (maybe jus the central ones - not sure, did the
>> lot) sorted that one out!
>>
>> Ronnie
>>
>>> I've installed build 215 of Resharper 2.0 with VS 2005 and i keep
>>> getting the following error on VS 2005 startup
>>>
>>> "Resharper has failed to retrieve one of its Fonts and Colors
>>> entries
>>> ('Resharper Current Line').
>>> This is usually an indication that Fonts and Colors entries are
>>> corrupt.
>>> Please make sure that Resharper is property installed.
>>> You can also try to run 'devenv.exe /setup' from the command line."
>>> I tried running devenv.exe /setup but that didn't fix it. I can use
>>> resharper just fine. I tried searching the newsgroup but found
>>> nothing.
>>> Any ideas.
>>> Thanks
>>>
>>> Zeid
>>>


0
Comment actions Permalink

Hello Gabriel,

actually the problem with disappearance of ReSharper's Fonts and Colors entries
happens mostly on VS 2005.
In VS 2003, however, the error message box somehow managed to display even
if there are actually ReShaper Fonts
and Color entries! I mean, they present in Fonts and Colors dialog but are
inaccesible via API. Perhaps there is an
initialization order problem here, or something similar, but we've decided
not to spend time investigating it further and
will better try to understand why ReSharper Fonts and Color entries are missing
from time to time.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Dmitry,

I believed that this issue was related to Visual Studio 2003. I
haven't encountered this error yet on Visual Studio 2005.

Gabriel Lozano-Morán
MCSD .NET
Real Software
http://www.realsoftware.be
http://www.realdn.net

>> Hello Ronnie,
>>
>> this error message seemed to happen intermittently and we disabled
>> it.
>> There
>> is a problem, however, that on VS 2005
>> ReSharper Fonts and Colors entries sometimes disappear, and
>> 'devenv.exe /setup'
>> doesn't fix it.
>> We're investigating this now.
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Hello Zeid,
>>>
>>> I suddenly had that after a few days with 215 - found that deleting
>>> all of the caches (maybe jus the central ones - not sure, did the
>>> lot) sorted that one out!
>>>
>>> Ronnie
>>>
>>>> I've installed build 215 of Resharper 2.0 with VS 2005 and i keep
>>>> getting the following error on VS 2005 startup
>>>>
>>>> "Resharper has failed to retrieve one of its Fonts and Colors
>>>> entries
>>>> ('Resharper Current Line').
>>>> This is usually an indication that Fonts and Colors entries are
>>>> corrupt.
>>>> Please make sure that Resharper is property installed.
>>>> You can also try to run 'devenv.exe /setup' from the command line."
>>>> I tried running devenv.exe /setup but that didn't fix it. I can
>>>> use
>>>> resharper just fine. I tried searching the newsgroup but found
>>>> nothing.
>>>> Any ideas.
>>>> Thanks
>>>> Zeid
>>>>


0
Comment actions Permalink

Hello Dmitry,

FYI: I'm on VS2003!

Hello Ronnie,

this error message seemed to happen intermittently and we disabled it.
There
is a problem, however, that on VS 2005
ReSharper Fonts and Colors entries sometimes disappear, and
'devenv.exe /setup'
doesn't fix it.
We're investigating this now.
Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> Hello Zeid,
>>
>> I suddenly had that after a few days with 215 - found that deleting
>> all of the caches (maybe jus the central ones - not sure, did the
>> lot) sorted that one out!
>>
>> Ronnie
>>
>>> I've installed build 215 of Resharper 2.0 with VS 2005 and i keep
>>> getting the following error on VS 2005 startup
>>>
>>> "Resharper has failed to retrieve one of its Fonts and Colors
>>> entries
>>> ('Resharper Current Line').
>>> This is usually an indication that Fonts and Colors entries are
>>> corrupt.
>>> Please make sure that Resharper is property installed.
>>> You can also try to run 'devenv.exe /setup' from the command line."
>>> I tried running devenv.exe /setup but that didn't fix it. I can use
>>> resharper just fine. I tried searching the newsgroup but found
>>> nothing.
>>> Any ideas.
>>> Thanks
>>>
>>> Zeid
>>>


0

Please sign in to leave a comment.