[230] Slow performance when typing method parameters

Hi all,

I'm still experiencing serious lags (typed text only appears after a few
seconds) when typing method parameters, this occurs on my system since build
229. Is this a known issue, do others experience this as well?

Guy


9 comments
Comment actions Permalink

I've also seen this, appear to be related to the parameter info, I turned this off and it was usable again.

0
Comment actions Permalink


"alastair"

I've also seen this, appear to be related to the parameter info, I turned
this off and it was usable again.


Disabling feautures - is not a way, its something wrong.



0
Comment actions Permalink

I agree 100%, I'm just pointing to the culprit.

0
Comment actions Permalink

Disabling feautures - is not a way, its something wrong.


Absolutely. But such posts help us to locate origins of the problems.

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

"alastair"

>> I've also seen this, appear to be related to the parameter info, I
>> turned this off and it was usable again.
>>

Disabling feautures - is not a way, its something wrong.



0
Comment actions Permalink

Guy,

Does disabling Parameter Info help you too or not?

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi all,

I'm still experiencing serious lags (typed text only appears after a
few seconds) when typing method parameters, this occurs on my system
since build 229. Is this a known issue, do others experience this as
well?

Guy



0
Comment actions Permalink

Hello Valentin,

Yes, disabling the auto-popup does make the editor respond better, and thus
typing goes a lot smoother.

But displaying the autocompletion popup also goes too slow to give a smooth
experience. I find myself waiting for the editor to catch up when I'm accessing
a member that is a few levels deep, like: context.State.CurrentTable.Foo()
and pressing ctrl-shift-space whenever I think a single option can be chosen
by r#.

Greetings,

Guy

Guy,

Does disabling Parameter Info help you too or not?

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> Hi all,
>>
>> I'm still experiencing serious lags (typed text only appears after a
>> few seconds) when typing method parameters, this occurs on my system
>> since build 229. Is this a known issue, do others experience this as
>> well?
>>
>> Guy
>>


0
Comment actions Permalink

Hello Guy,

Is it the same in #231?

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Valentin,

Yes, disabling the auto-popup does make the editor respond better, and
thus typing goes a lot smoother.

But displaying the autocompletion popup also goes too slow to give a
smooth experience. I find myself waiting for the editor to catch up
when I'm accessing a member that is a few levels deep, like:
context.State.CurrentTable.Foo() and pressing ctrl-shift-space
whenever I think a single option can be chosen by r#.

Greetings,

Guy

>> Guy,
>>
>> Does disabling Parameter Info help you too or not?
>>
>> Valentin Kipiatkov
>> Chief Scientist, Vice President of Product Development
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Hi all,
>>>
>>> I'm still experiencing serious lags (typed text only appears after a
>>> few seconds) when typing method parameters, this occurs on my system
>>> since build 229. Is this a known issue, do others experience this
>>> as well?
>>>
>>> Guy
>>>


0
Comment actions Permalink

Hello Valentin,

My previous post was about #231; I do have references to 24 dll's, some of
which could be rather large but I only have one relatively small project
in my solution. It's not that I'm on an slow machine, I have P4 3.2Ghz with
1gb of ram (and not all of it is used :)).

I have noticed that the lags seem to occur for types that reside in the dlls
rather than the ones from my own code.

Greetings,

Guy

Hello Guy,

Is it the same in #231?

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> Hello Valentin,
>>
>> Yes, disabling the auto-popup does make the editor respond better,
>> and thus typing goes a lot smoother.
>>
>> But displaying the autocompletion popup also goes too slow to give a
>> smooth experience. I find myself waiting for the editor to catch up
>> when I'm accessing a member that is a few levels deep, like:
>> context.State.CurrentTable.Foo() and pressing ctrl-shift-space
>> whenever I think a single option can be chosen by r#.
>>
>> Greetings,
>>
>> Guy
>>
>>> Guy,
>>>
>>> Does disabling Parameter Info help you too or not?
>>>
>>> Valentin Kipiatkov
>>> Chief Scientist, Vice President of Product Development
>>> JetBrains, Inc
>>> http://www.jetbrains.com
>>> "Develop with pleasure!"
>>>> Hi all,
>>>>
>>>> I'm still experiencing serious lags (typed text only appears after
>>>> a few seconds) when typing method parameters, this occurs on my
>>>> system since build 229. Is this a known issue, do others
>>>> experience this as well?
>>>>
>>>> Guy
>>>>


0
Comment actions Permalink

At first it appears to be working well, then gets slower and slower. I went all the way back to 224 and the same thing, it's fast for about an hour then just get unusable.

0

Please sign in to leave a comment.