Horrible VS 2005 crashes in generic library

I'm currently working on a generic library in VS2005 and the IDE behaves
horribly - it crashes all the time. I'm working on #233.

Typical scenario: I'm trying to invoke a method (same class). As soon as
I've typed the full method name (without even typing the opending
bracket), VS crashes. I've ended up typing such code in a text editor
and posting it as a block (which works), but come on...

This behaviour is reproducable for the method (I can play the edit/crash
thing as long as I want), others work at the same time. After having
modified the code etc, method invocation works until the next time. The
only common thing seem to be generics - other solutions work just fine.

I tried to debug the IDE, but didn't get that far - even the debugging
IDE crashes (at least, I could submit an exception to the JetBrains
tracker).

I know this is very few information, but any hints?

Cheers,
Philipp

1 comment
Comment actions Permalink

1) Have you any other VS add-ons installed?

2) While debugging, do not run another VS, but CLR debugger instead.
And enable break on all exceptions just before you make the debugee VS crash

--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Philipp Sumi" <nospam@this.domain.doesnotexist.xxx> wrote in message
news:e1g04e$ndc$1@is.intellij.net...

I'm currently working on a generic library in VS2005 and the IDE behaves
horribly - it crashes all the time. I'm working on #233.

>

Typical scenario: I'm trying to invoke a method (same class). As soon as
I've typed the full method name (without even typing the opending
bracket), VS crashes. I've ended up typing such code in a text editor and
posting it as a block (which works), but come on...

>

This behaviour is reproducable for the method (I can play the edit/crash
thing as long as I want), others work at the same time. After having
modified the code etc, method invocation works until the next time. The
only common thing seem to be generics - other solutions work just fine.

>

I tried to debug the IDE, but didn't get that far - even the debugging IDE
crashes (at least, I could submit an exception to the JetBrains tracker).

>

I know this is very few information, but any hints?

>

Cheers,
Philipp



0

Please sign in to leave a comment.