[ 240 ] Smart indent on Enter

I am using 240 in VS2005. I have the VS option
TextEditor->C#->Tabs->Indenting set to “Smart”. If R# is enabled, every
time I press Enter my cursor is moved to the beginning of the line (no
indent). I have tried playing with the R# Option Editor->Smart indent
on Enter but, as far as I can tell, this setting does not do anything.

If I set the VS setting to "None", regardless of whether the R# option
is checked, my cursor is moved to the beginning of the line (no indent).
If I turn the VS setting to "Smart", regardless of whether the R#
setting is checked, my cursor is moved to the beginning of the line.

Is anyone else seeing this problem? It is extremely annoying. Is there
some setting that I have not seen which can fix this problem? I do not
have this problem using VS2003.

- Nate

1 comment
Comment actions Permalink

Just curious, but have you restarted Visual Studio or rebooted the computer?
I only ask because I was seeing "funny" stuff on line indenting (in my case,
it wasn't "lining up" correctly, using being off by one space either too
much indent or not enough) but the problem went away after restarting my
computer.

"Nate Zobrist" <zobie@zobie.com> wrote in message
news:e3insg$qup$1@is.intellij.net...
>I am using 240 in VS2005. I have the VS option
>TextEditor->C#->Tabs->Indenting set to ?Smart?. If R# is enabled, every
>time I press Enter my cursor is moved to the beginning of the line (no
>indent). I have tried playing with the R# Option Editor->Smart indent on
>Enter but, as far as I can tell, this setting does not do anything.
>

If I set the VS setting to "None", regardless of whether the R# option is
checked, my cursor is moved to the beginning of the line (no indent). If I
turn the VS setting to "Smart", regardless of whether the R# setting is
checked, my cursor is moved to the beginning of the line.

>

Is anyone else seeing this problem? It is extremely annoying. Is there
some setting that I have not seen which can fix this problem? I do not
have this problem using VS2003.

>

- Nate



0

Please sign in to leave a comment.