4 comments
Comment actions Permalink

After deleting these extra templates and using R# for the last 15 minutes I've noticed that the typing lag that I have been experiencing is now almost completely gone (almost as fast as 1.5!). Are extra templates of the same name a possible cause of the slowdown?!?

0
Comment actions Permalink

Mike,
do you have completion autopopup on typing turned on?

Friendly,
Dmitry

After deleting these extra templates and using R# for the last 15
minutes I've noticed that the typing lag that I have been experiencing
is now almost completely gone (almost as fast as 1.5!). Are extra
templates of the same name a possible cause of the slowdown?!?

--
Dmitry Lomov
Senior Software Developer
JetBrains, Inc.
"Develop With Pleasure!"


0
Comment actions Permalink

Yes, I believe so... I've attached a screen shot of my settings.

Unfortunately, the slowness is back. It's very inconsistent (and frustrating). Sometimes R# is very fast. Other times it is very slow. I can't seem to find any commonality/cause as to why it slows down. Sometimes restarting VS helps out, sometimes it doesn't.



Attachment(s):
resharper_code_completion_settings.png
0
Comment actions Permalink

The bug with 'defaultBodyTemplates' templates appearing is fixed in the build
#253. After installing this build, remove them all and they will never appear
again (we beleive so).

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

While running 250 I deleted three or so of the extra
defaultBodyTemplates in my User Templates.  Now in 251 they are back.
See attached screenshot.



0

Please sign in to leave a comment.