Refactor menu slowness

Is anyone else experiencing this?

If I select a block of code, and then either hit the "refactor this"
keystroke, or right-click the selection and select "Refactor...", there's a
VERY LONG delay, with no UI feedback, before the refactoring menu comes up.
I'm talking a minimum of 10 full seconds, sometimes longer.

That strikes me as being completely unreasonable... didn't this use to be
very fast?

I'm running the latest eap build on VS2005.


5 comments
Comment actions Permalink

While not 10 seconds, I see about a 3 second delay using 252 and VS2003, don't remember it doing this before although I've read about it here.

0
Comment actions Permalink

Paul Bradshaw wrote:

Is anyone else experiencing this?


Same thing here as posted on June, 13. I'm glad it's not only my machine
:)

Cheers, Philipp

0
Comment actions Permalink

We identified the reason of this delay and will fix it in the bugfix update.
Thanks!

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Is anyone else experiencing this?

If I select a block of code, and then either hit the "refactor this"
keystroke, or right-click the selection and select "Refactor...",
there's a VERY LONG delay, with no UI feedback, before the refactoring
menu comes up. I'm talking a minimum of 10 full seconds, sometimes
longer.

That strikes me as being completely unreasonable... didn't this use to
be very fast?

I'm running the latest eap build on VS2005.



0
Comment actions Permalink

Excellent news!  Thanks!

"Valentin Kipiatkov (JetBrains)" <valentin@jetbrains.com> wrote in message
news:3fdb29a6c98168c8639033d60f21@news.intellij.net...

We identified the reason of this delay and will fix it in the bugfix
update. Thanks!

>

Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> Is anyone else experiencing this?
>>
>> If I select a block of code, and then either hit the "refactor this"
>> keystroke, or right-click the selection and select "Refactor...",
>> there's a VERY LONG delay, with no UI feedback, before the refactoring
>> menu comes up. I'm talking a minimum of 10 full seconds, sometimes
>> longer.
>>
>> That strikes me as being completely unreasonable... didn't this use to
>> be very fast?
>>
>> I'm running the latest eap build on VS2005.
>>
>



0
Comment actions Permalink

I can confirm this is fixed in build 253, thank you!

0

Please sign in to leave a comment.