3 comments
Comment actions Permalink

I see this problem as well, on all kinds of size documents. It happens less
with the latest EAP releases, but it still happens. Sometimes restarting
VS will solve the problem, but sometimes I have to restart the computer.
That always works, though.

Some "different" things about my setup:
I span VS accross two monitors, with one file displayed on each monitor.
This means VS is never maxmized, it is sized manually.
I have Visual Assist X installed.
I have 2GB of RAM on a dual 3.0Ghz PC.
My PC has 3 monitors attached.
All the latest XP patches and such.

Can't think of anything else that would be distinctive from what you've heard
about his problem before.

John

Hello Daniel,

perhaps there is a memory leak or something like that somewhere
(ReSharper
including) that causes
typing performance to degrade eventually. We're currently studying
ReSharper
behavior from memory
leaks viewpoint. Am I right that delay doesn't happen when you start
VS from
scratch?
Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> I have GhostDoc, "Paste XML as XLinq" and Resharper installed.
>> This happens not every time, but after I used VS for a long time
>> without
>> restarting it and opening/closing different solutions.
>> "Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> schrieb im
>> Newsbeitrag news:c8a894d91b6b058c892b51028e393@news.intellij.net...
>>> Hello Daniel,
>>>
>>> this is kind of strange. On files of such size there should be no
>>> any
>>> delay incurred by ReSharper.
>>> Does disabling ReSharper help to get rid of the problem? Do you have
>>> any
>>> other add-ins installed?
>>> Thanks.
>>> Dmitry Shaporenkov
>>> JetBrains, Inc
>>> http://www.jetbrains.com
>>> "Develop with pleasure!"
>>>> 56 lines.
>>>> It is a new project with only 1 class and 2 methods in single
>>>> Program.cs
>>>> file.
>>>> "Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> schrieb im
>>>> Newsbeitrag news:c8a894d91b6b028c8925c4541cda7@news.intellij.net...
>>>>> Hello Daniel,
>>>>>
>>>>> does it depend on the size of the file you're typing in? Thanks.
>>>>>
>>>>> Regards,
>>>>> Dmitry Shaporenkov
>>>>> JetBrains, Inc
>>>>> http://www.jetbrains.com
>>>>> "Develop with pleasure!"
>>>>>> On 1.3Ghz CPU Build 258 is very slow. I have to wait almost 1sec
>>>>>> for every character (with enabled resharper intellisense).
>>>>>> Scrolling through intellisense popup (after typing . ) takes 80%
>>>>>> CPU.
>>>>>>


0
Comment actions Permalink

Hello John,

with regard to your environment, it would be interesting for us to know how
disabling Visual Assist affects the problem?

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I see this problem as well, on all kinds of size documents. It happens
less with the latest EAP releases, but it still happens. Sometimes
restarting VS will solve the problem, but sometimes I have to restart
the computer. That always works, though.

Some "different" things about my setup:
I span VS accross two monitors, with one file displayed on each
monitor.
This means VS is never maxmized, it is sized manually.
I have Visual Assist X installed.
I have 2GB of RAM on a dual 3.0Ghz PC.
My PC has 3 monitors attached.
All the latest XP patches and such.
Can't think of anything else that would be distinctive from what
you've heard about his problem before.

John

>> Hello Daniel,
>>
>> perhaps there is a memory leak or something like that somewhere
>> (ReSharper
>> including) that causes
>> typing performance to degrade eventually. We're currently studying
>> ReSharper
>> behavior from memory
>> leaks viewpoint. Am I right that delay doesn't happen when you start
>> VS from
>> scratch?
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> I have GhostDoc, "Paste XML as XLinq" and Resharper installed.
>>> This happens not every time, but after I used VS for a long time
>>> without
>>> restarting it and opening/closing different solutions.
>>> "Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> schrieb im
>>> Newsbeitrag news:c8a894d91b6b058c892b51028e393@news.intellij.net...
>>>> Hello Daniel,
>>>>
>>>> this is kind of strange. On files of such size there should be no
>>>> any
>>>> delay incurred by ReSharper.
>>>> Does disabling ReSharper help to get rid of the problem? Do you
>>>> have
>>>> any
>>>> other add-ins installed?
>>>> Thanks.
>>>> Dmitry Shaporenkov
>>>> JetBrains, Inc
>>>> http://www.jetbrains.com
>>>> "Develop with pleasure!"
>>>>> 56 lines.
>>>>> It is a new project with only 1 class and 2 methods in single
>>>>> Program.cs
>>>>> file.
>>>>> "Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> schrieb im
>>>>> Newsbeitrag
>>>>> news:c8a894d91b6b028c8925c4541cda7@news.intellij.net...
>>>>>> Hello Daniel,
>>>>>>
>>>>>> does it depend on the size of the file you're typing in? Thanks.
>>>>>>
>>>>>> Regards,
>>>>>> Dmitry Shaporenkov
>>>>>> JetBrains, Inc
>>>>>> http://www.jetbrains.com
>>>>>> "Develop with pleasure!"
>>>>>>> On 1.3Ghz CPU Build 258 is very slow. I have to wait almost 1sec
>>>>>>> for every character (with enabled resharper intellisense).
>>>>>>> Scrolling through intellisense popup (after typing . ) takes 80%
>>>>>>> CPU.
>>>>>>>


0
Comment actions Permalink

Yes, imidiatly after starting VS delay doesn't happen.

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> schrieb im Newsbeitrag
news:c8a894d91b6b128c893530f70d0e1@news.intellij.net...

Hello Daniel,

>

perhaps there is a memory leak or something like that somewhere (ReSharper
including) that causes
typing performance to degrade eventually. We're currently studying
ReSharper behavior from memory
leaks viewpoint. Am I right that delay doesn't happen when you start VS
from scratch?

>
>

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> I have GhostDoc, "Paste XML as XLinq" and Resharper installed.
>> This happens not every time, but after I used VS for a long time
>> without
>> restarting it and opening/closing different solutions.
>> "Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> schrieb im
>> Newsbeitrag news:c8a894d91b6b058c892b51028e393@news.intellij.net...
>>
>>> Hello Daniel,
>>>
>>> this is kind of strange. On files of such size there should be no any
>>> delay incurred by ReSharper.
>>> Does disabling ReSharper help to get rid of the problem? Do you have
>>> any
>>> other add-ins installed?
>>> Thanks.
>>> Dmitry Shaporenkov
>>> JetBrains, Inc
>>> http://www.jetbrains.com
>>> "Develop with pleasure!"
>>>> 56 lines.
>>>> It is a new project with only 1 class and 2 methods in single
>>>> Program.cs
>>>> file.
>>>> "Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> schrieb im
>>>> Newsbeitrag news:c8a894d91b6b028c8925c4541cda7@news.intellij.net...
>>>>> Hello Daniel,
>>>>>
>>>>> does it depend on the size of the file you're typing in? Thanks.
>>>>>
>>>>> Regards,
>>>>> Dmitry Shaporenkov
>>>>> JetBrains, Inc
>>>>> http://www.jetbrains.com
>>>>> "Develop with pleasure!"
>>>>>> On 1.3Ghz CPU Build 258 is very slow. I have to wait almost 1sec
>>>>>> for every character (with enabled resharper intellisense).
>>>>>> Scrolling through intellisense popup (after typing . ) takes 80%
>>>>>> CPU.
>>>>>>
>
>



0

Please sign in to leave a comment.