Build 447 has no license

I just installed 3.0 build 447 on top of build 423 and am unable to activate it. I was using 423 with the published generic eval license that expired on the 29th. After installing 447 and starting Visual Studio 2005 I am prompted for a new license since the generic eval license expired. Yet no new license key has been released. I am not offered the ability to select a 30-day eval even though the EAP download page states that this is the new license model as of build 406.

I also tried to uninstall build 447 and then reinstall it with no success.

What gives?

7 comments
Comment actions Permalink

I'm in the same boat.

0
Comment actions Permalink

I'm afraid you have to manually remove temporary licenses from your UserSettings.xml
file.
It is located in the "C:\Documents and Settings\\Application Data\JetBrains\ReSharper\v3.0" folder or one of it subfolders (vs8.0, vs9.0) Close VS, find and remove these tags: ]]>

After that, free evaluation should be available.

Actually, I recommend everyone to do so, because in 3.0 temporary EAP licenses
are somewhat unsupported scenario, used because of bugs in early builds.
Now it should be corrected.

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

It doesn't work for me. And there are 2 ReSharper menus.

My previous version is b423. I uninstalled it before install b447.

0
Comment actions Permalink

In my computer there are 2 folders "C:\Documents and Settings\\Application Data\JetBrains\ReSharper\v3.0" and "C:\Documents and Settings\\Application Data\JetBrains\ReSharper3". These folders contain UserSettings.xml with license information. I delete the tags from UserSettings.xml in "C:\Documents and Settings\\Application Data\JetBrains\ReSharper3" but it didn't work. Then I deleted the tags from UserSettings.xml in "C:\Documents and Settings\\Application Data\JetBrains\ReSharper\v3.0" and it worked. In my case, I only found these tags: ]]>

There are still 2 ReSharper menus even I reinstalled b447.

0
Comment actions Permalink

Hello t800t8,

in order to get rid of the redundant second menu left from older builds,
you can chose Tools|Import and Export Settings|Reset
All Settings. This is a one-time operation that doesn't need to be redone
in future.


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


It doesn't work for me. And there are 2 ReSharper menus.

My previous version is b423. I uninstalled it before install b447.



0
Comment actions Permalink

I have removed the Resharper2 and Resharper3 folders, only to keep Resharper\v3.0
It works fine.

In my computer there are 2 folders "C:\Documents and
Settings\<USER>\Application Data\JetBrains\ReSharper\v3.0" and
"C:\Documents and Settings\<USER>\Application
Data\JetBrains\ReSharper3". These folders contain UserSettings.xml
with license information. I delete the tags from UserSettings.xml in
"C:\Documents and Settings\<USER>\Application
Data\JetBrains\ReSharper3" but it didn't work. Then I deleted the tags
from UserSettings.xml in "C:\Documents and Settings\<USER>\Application
Data\JetBrains\ReSharper\v3.0" and it worked.

In my case, I only found these tags:
<setting name="License">
<setting name="LicenseMode">
<setting name="Username">
There are still 2 ReSharper menus even I reinstalled b447.



0
Comment actions Permalink

Thanks, it works.

0

Please sign in to leave a comment.