Unable to revert to 2.5.2; NullReferenceException when running tests

Hi everyone,

I tried 3.0 beta and build #452, but I wanted to revert to 2.5.2. After doing so, I can't use the Test Runner. Every time I try to run any tests, I get a NullReferenceException. I reported it to Jira twice via R#, but I can't remember the # or find it in Jira right now.

Has anyone successfully reinstalled 2.5.2 after trying 3.0 beta or later builds? If so, did you do anything special that I might not have thought to do?

Thanks,
Craig

2 comments
Comment actions Permalink

Hello Craig,

I've answered you in JIRA, but will copy it here:

It is already fixed in latest builds, but you may have to manually fix the
problem - find SolutionName.resharper.user file near your SLN file and remove
xml element. This should fix it for 2.5. Sorry for inconvenience. Sincerely, Ilya Ryzhenkov JetBrains, Inc http://www.jetbrains.com "Develop with pleasure!" CD> Hi everyone, CD> CD> I tried 3.0 beta and build #452, but I wanted to revert to 2.5.2. CD> After doing so, I can't use the Test Runner. Every time I try to run CD> any tests, I get a NullReferenceException. I reported it to Jira CD> twice via R#, but I can't remember the # or find it in Jira right CD> now. CD> CD> Has anyone successfully reinstalled 2.5.2 after trying 3.0 beta or CD> later builds? If so, did you do anything special that I might not CD> have thought to do? CD> CD> Thanks, CD>]]> Craig


0
Comment actions Permalink

Thanks! That did the trick.

0

Please sign in to leave a comment.