Space inserted after auto-complete

I'm not sure if this is a bug or just the way it works but when I turn off "Automatically insert parentheses after completion", if I do an auto-complete (press Tab, Enter, CtrlAltSpace, etc.), my item is auto-completed and a space is immediately dropped after the completed item. The problem is that if I'm doing something like this:

Customer c = new Cust I wind up with Customer c = new Customer ]]>

So if I add my open paren, it'd look like:

Customer c = new Customer (

instead of

Customer c = new Customer(

Since it's one space after the type, when I drop that open paren, I don't get my parameter lists. I have to backspace and then drop the open paren.

Is this the intended behavior or is there some other setting I need to enable/disable?

Thanks!

Brian Peek

1 comment
Comment actions Permalink

It appears that it might be a bug, but as a work-around for you, you can simply hit CTRL-P (if you're using the IDEA bindings) to open your prameter list, regardless of the spacing between the paren and the declaration.

You, alternatively can have it automatically insert only the opening paren, and that would seem to achieve your desired behavior, though.

0

Please sign in to leave a comment.