CTRL+N delay still there in 3.0 RC

build 3.0.465.20

In v2.5, a really annoying delay was introduced in CTRL+N and filter boxes similar to it. With 2.0, I could begin typing, and the list would IMMEDIATELY show up. With 2.5, there was a small lag introduced. I had to stop typing, wait for the list to pop up, and then type some more.

I emailed support and was told that this delay was going to be configurable. I have searched the new options, and I can't find how to turn off this delay.

Please let me know how to turn off the delay. The delay is VERY annoying.

Best regards,
Jeffrey Palermo, C# MVP

7 comments
Comment actions Permalink

Hello,

In v2.5, a really annoying delay was introduced in CTRL+N and filter
boxes similar to it. With 2.0, I could begin typing, and the list
would IMMEDIATELY show up. With 2.5, there was a small lag
introduced. I had to stop typing, wait for the list to pop up, and
then type some more.

Please let me know how to turn off the delay. The delay is VERY annoying.


The delay is not configurable yet.

You don't have to stop typing, you can hit Enter to accept the first item
in the list right after typing the last character.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Serge,
Thank you for the response. Please at least give me a hack to turn off this delay. It is a major regression from my experience with Resharper 2.0.

I rarely pick the first item in the list. I prefer not to type that much. I'd like to type just enough to see the item. Then I'll arrow down once or twice and hit enter to select the correct one.

Will this be complete before RTM?

Best regards,
Jeffrey Palermo, Microsoft MVP

0
Comment actions Permalink

Jeffrey Palermo wrote:

Thank you for the response. Please at least give me a hack to turn off this delay. It is a major regression from my experience with Resharper 2.0.

I rarely pick the first item in the list. I prefer not to type that much. I'd like to type just enough to see the item. Then I'll arrow down once or twice and hit enter to select the correct one.


Hi Jeffrey,

Do you know the CamelHumps feature in the Go To Type list? If not, check
this out:

http://excastle.com/blog/archive/2007/02/10/14416.aspx


Ciao,
Jens

--
http://www.jenswinter.com

0
Comment actions Permalink

Hello,

No features can be added before RTM, that is for sure.

However, I've checked the source code and found that indeed there is a setting
for this delay. The setting has never been added to the Options (and was
not intended to be added). But it's still accessible from the user settings
file (UserSettings.xml in the roaming application data folder in the user
profile) under the “UserInputDeferTime” name.

The major use case for the “Goto By Name”-family dialogs is entering an acronym
for the desired type (just the uppercase letters are required, the lowercases
should be added only to disambig) and hitting Enter, or picking a type from
the list. In this case it's very important to avoid recalculating the list
on each and every keystroke (which prevents from typing more characters immediately),
and that was the main motive for introducing the delay that accumulates the
entered characters before building the list.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Jens,
Thank you for the tip. Yes, I use this feature as well.

Best regards,
Jeffrey Palermo

0
Comment actions Permalink

However, I've checked the source code and found that
indeed there is a setting
for this delay. The setting has never been added to
the Options (and was
not intended to be added). But it's still accessible
from the user settings
file (UserSettings.xml in the roaming application
data folder in the user
profile) under the “UserInputDeferTime” name.


Serge,
Thank you. This is what I need! I changed the setting to "0", and it had no effect, but when I changed it to "1", it does what I want. I still have to pause typing for I tiny, tiny bit, but it is much better than having to wait for 1/3 of a second for the list to filter. I have no idea why 1/3 of a second was chosen for the delay.

I'd invite you to change this to "1" and judge the experience for yourself. Perhaps this setting can be changed for RTM.

Thank you for the workaround.

Best regards,
Jeffrey Palermo

0
Comment actions Permalink

Hello,

Thank you. This is what I need! I changed the setting to "0", and it
had no effect, but when I changed it to "1", it does what I want. I
still have to pause typing for I tiny, tiny bit, but it is much better
than having to wait for 1/3 of a second for the list to filter. I
have no idea why 1/3 of a second was chosen for the delay.
I'd invite you to change this to "1" and judge the experience for
yourself. Perhaps this setting can be changed for RTM.


Surely not for the RTM, but it's quite possible in the next version. The
list will be calculated in another thread, so the delay will not be needed
at all. It's already half-done, actually ;)


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.