[301] Intellisense

I need some help getting Intellisense working with 301. When I first installed 301, I was getting both Visual Studio and ReSharper Intellisense. I first verified ReSharper is set to "Use Intellisense features of ReSharper" and I continue to receive Intellisense from both. I thought I was doing the right thing by selecting Tools | Options, expanding Text Editor, C#, General, and disabling "Auto list members." When I disable this feature, I receive only ReSharper's Intellisense, but the option keeps turning itself back on when I restart Visual Studio.

I also tried turning off Intellisense (Text Editor, C#, Intellisense), but when I do this I get no Intellisense at all.

5 comments
Comment actions Permalink

Check out the thread - news://news.jetbrains.com/eir8fs$kn8$1@is.intellij.net


I need some help getting Intellisense working with 301. When I first
installed 301, I was getting both Visual Studio and ReSharper
Intellisense. I first verified ReSharper is set to "Use Intellisense
features of ReSharper" and I continue to receive Intellisense from
both. I thought I was doing the right thing by selecting Tools |
Options, expanding Text Editor, C#, General, and disabling "Auto list
members." When I disable this feature, I receive only ReSharper's
Intellisense, but the option keeps turning itself back on when I
restart Visual Studio.

I also tried turning off Intellisense (Text Editor, C#, Intellisense),
but when I do this I get no Intellisense at all.



0
Comment actions Permalink

Sorry - not sure if that previous link worked....here's the text instead:

Hi,

I get the same. I turn off all my intellisense options in VS, including

three under Text Editor | C# | General | Statement Completion and Text Editor

All Languages

General

Statement Completion. I have to go back in and
turn them off every now and again though....maybe a VS thing?


I'm also seeing this issue, however, was able to work around it by disabling
R# in the Tools->AddIns menu, clearing the VS auto-format options and then
enabling R# again.

I forget if I exited VS before re-enabling R#, so you may have to try this
twice ;)

Yours,
Morten

> I need some help getting Intellisense working with 301. When I first
> installed 301, I was getting both Visual Studio and ReSharper
> Intellisense. I first verified ReSharper is set to "Use Intellisense
> features of ReSharper" and I continue to receive Intellisense from
> both. I thought I was doing the right thing by selecting Tools

Options, expanding Text Editor, C#, General, and disabling "Auto list
members." When I disable this feature, I receive only ReSharper's
Intellisense, but the option keeps turning itself back on when I
restart Visual Studio.

I also tried turning off Intellisense (Text Editor, C#, Intellisense),
but when I do this I get no Intellisense at all.



0
Comment actions Permalink

Thanks. The link worked fine. I'll try this later tonight or in the morning.

--


"Sean Kearon" <no@spam.org> wrote in message
news:adc66bd2cc98c8d724177fb1d6@news.jetbrains.com...

Sorry - not sure if that previous link worked....here's the text instead:

>

Hi,

>
>> I get the same. I turn off all my intellisense options in VS, including

three under Text Editor | C# | General | Statement Completion and Text
Editor | All Languages | General | Statement Completion. I have to go back
in and turn them off every now and again though....maybe a VS thing?

>
>

I'm also seeing this issue, however, was able to work around it by
disabling R# in the Tools->AddIns menu, clearing the VS auto-format
options and then enabling R# again.

>

I forget if I exited VS before re-enabling R#, so you may have to try this
twice ;)

>

Yours,
Morten

>
>> I need some help getting Intellisense working with 301. When I first
>> installed 301, I was getting both Visual Studio and ReSharper
>> Intellisense. I first verified ReSharper is set to "Use Intellisense
>> features of ReSharper" and I continue to receive Intellisense from
>> both. I thought I was doing the right thing by selecting Tools |
>> Options, expanding Text Editor, C#, General, and disabling "Auto list
>> members." When I disable this feature, I receive only ReSharper's
>> Intellisense, but the option keeps turning itself back on when I
>> restart Visual Studio.
>>
>> I also tried turning off Intellisense (Text Editor, C#, Intellisense),
>> but when I do this I get no Intellisense at all.
>>
>



0
Comment actions Permalink

This is a known bug and we plan to fix it. Until that you have to run "Auto
list members" (and also "Parameter information") after each VisualStudio
start.

Valentin Kipiatkov
CTO and Chief Scientist
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I need some help getting Intellisense working with 301. When I first
installed 301, I was getting both Visual Studio and ReSharper
Intellisense. I first verified ReSharper is set to "Use Intellisense
features of ReSharper" and I continue to receive Intellisense from
both. I thought I was doing the right thing by selecting Tools |
Options, expanding Text Editor, C#, General, and disabling "Auto list
members." When I disable this feature, I receive only ReSharper's
Intellisense, but the option keeps turning itself back on when I
restart Visual Studio.

I also tried turning off Intellisense (Text Editor, C#, Intellisense),
but when I do this I get no Intellisense at all.



0
Comment actions Permalink

Have you fixed this yet? I have this annoying problem too.

0

Please sign in to leave a comment.