Poor Performance with R# and ASP.NET

I've been working on a web application project this weekend, and the
performance with R# has been absolutely abysmal. It literally grinds the
IDE to a halt for many seconds at a time, quite often. I'm not sure what is
causing it, but I'm using ASP.NET 3.5 and Infragistics NetAdvantage 2008
(though I had the same issue without NetAdvantage). If I disable R#, then
the IDE starts performing normally again (neither terribly fast nor slow).
Has anyone else experienced this?

Regards,
Mike

5 comments
Comment actions Permalink

Mike,
What version of ReSharper are you using? Do you have solution-wide error
analysis switched on?

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Mike Strobel" <mstrobel@cdcsoftware.com> wrote in message
news:fqej95$3j5$1@is.intellij.net...

I've been working on a web application project this weekend, and the
performance with R# has been absolutely abysmal. It literally grinds the
IDE to a halt for many seconds at a time, quite often. I'm not sure what
is causing it, but I'm using ASP.NET 3.5 and Infragistics NetAdvantage
2008 (though I had the same issue without NetAdvantage). If I disable R#,
then the IDE starts performing normally again (neither terribly fast nor
slow). Has anyone else experienced this?

>

Regards,
Mike



0
Comment actions Permalink

At the time I was running the R# 4.0 nightly build from March 1, and I'm
installing the latest nightly build right now. I do not have solution-wide
analysis switched on.

Cheers,
Mike

"Sergey V. Coox (JetBrains)" <qx@intellij.com> wrote in message
news:fqgfvb$t9v$1@is.intellij.net...

Mike,
What version of ReSharper are you using? Do you have solution-wide error
analysis switched on?

>

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Mike Strobel" <mstrobel@cdcsoftware.com> wrote in message
news:fqej95$3j5$1@is.intellij.net...

>> I've been working on a web application project this weekend, and the
>> performance with R# has been absolutely abysmal. It literally grinds the
>> IDE to a halt for many seconds at a time, quite often. I'm not sure what
>> is causing it, but I'm using ASP.NET 3.5 and Infragistics NetAdvantage
>> 2008 (though I had the same issue without NetAdvantage). If I disable
>> R#, then the IDE starts performing normally again (neither terribly fast
>> nor slow). Has anyone else experienced this?
>>
>> Regards,
>> Mike
>


0
Comment actions Permalink

Fixed. Try tomorrow's nightly build

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Mike Strobel" <mstrobel@cdcsoftware.com> wrote in message
news:fqhgg2$gda$1@is.intellij.net...

At the time I was running the R# 4.0 nightly build from March 1, and I'm
installing the latest nightly build right now. I do not have
solution-wide analysis switched on.

>

Cheers,
Mike

>

"Sergey V. Coox (JetBrains)" <qx@intellij.com> wrote in message
news:fqgfvb$t9v$1@is.intellij.net...

>> Mike,
>> What version of ReSharper are you using? Do you have solution-wide error
>> analysis switched on?
>>
>> --
>> Sergey V. Coox
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>> "Mike Strobel" <mstrobel@cdcsoftware.com> wrote in message
>> news:fqej95$3j5$1@is.intellij.net...
>>> I've been working on a web application project this weekend, and the
>>> performance with R# has been absolutely abysmal. It literally grinds
>>> the IDE to a halt for many seconds at a time, quite often. I'm not sure
>>> what is causing it, but I'm using ASP.NET 3.5 and Infragistics
>>> NetAdvantage 2008 (though I had the same issue without NetAdvantage).
>>> If I disable R#, then the IDE starts performing normally again (neither
>>> terribly fast nor slow). Has anyone else experienced this?
>>>
>>> Regards,
>>> Mike
>>
>>



0
Comment actions Permalink

Oops. Misclick. Sorry

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Sergey V. Coox (JetBrains)" <qx@intellij.com> wrote in message
news:fqjqp3$hiu$1@is.intellij.net...


0
Comment actions Permalink

Great! I look forward to trying it out :).

Cheers,
Mike

"Sergey V. Coox (JetBrains)" <qx@intellij.com> wrote in message
news:fqjqp3$hiu$1@is.intellij.net...

Fixed. Try tomorrow's nightly build

>

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Mike Strobel" <mstrobel@cdcsoftware.com> wrote in message
news:fqhgg2$gda$1@is.intellij.net...

>> At the time I was running the R# 4.0 nightly build from March 1, and I'm
>> installing the latest nightly build right now. I do not have
>> solution-wide analysis switched on.
>>
>> Cheers,
>> Mike
>>
>> "Sergey V. Coox (JetBrains)" <qx@intellij.com> wrote in message
>> news:fqgfvb$t9v$1@is.intellij.net...
>>> Mike,
>>> What version of ReSharper are you using? Do you have solution-wide error
>>> analysis switched on?
>>>
>>> --
>>> Sergey V. Coox
>>> JetBrains, Inc
>>> http://www.jetbrains.com
>>> "Develop with pleasure!"
>>> "Mike Strobel" <mstrobel@cdcsoftware.com> wrote in message
>>> news:fqej95$3j5$1@is.intellij.net...
>>>> I've been working on a web application project this weekend, and the
>>>> performance with R# has been absolutely abysmal. It literally grinds
>>>> the IDE to a halt for many seconds at a time, quite often. I'm not
>>>> sure what is causing it, but I'm using ASP.NET 3.5 and Infragistics
>>>> NetAdvantage 2008 (though I had the same issue without NetAdvantage).
>>>> If I disable R#, then the IDE starts performing normally again (neither
>>>> terribly fast nor slow). Has anyone else experienced this?
>>>>
>>>> Regards,
>>>> Mike
>>>
>>>
>>
>


0

Please sign in to leave a comment.