R# 4.0 Build 751 - Unit Test Runner Broken

In so far as NUnit runs my unit tests successfully, and R# Unit Test runner doesn't, I consider this functionality broken in this build.
It doesn't find the (app).config and any dependencies that aren't dll files (i.e. marked as "Content" in the .csproj file)

12 comments
Comment actions Permalink

I am having the same error here.

0
Comment actions Permalink

app.config is "ignored"!

Edited by: Clemens Wyss on Mar 17, 2008 10:21 AM

0
Comment actions Permalink

Same problem here - I've rolled back to build 748 (08 Mar) which works ok

0
Comment actions Permalink

hopefully this gets solved soon. Shouldn't be that hard, as it was still ok in 748....

0
Comment actions Permalink

Confirming that I'm also having this problem in 755.

0
Comment actions Permalink

Hello Will,

Do you have "Specific folder" selected in "Options / Tools / Unit Testing"?
If so, do you have correct path entered there and app.config copied to that
path?

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


WS> Confirming that I'm also having this problem in 755.
WS>


0
Comment actions Permalink

I am not Will, but I have "Project output folder" selected, ie no specific folder...
What was changed (in UnitTesting) between 748 and and 752?

0
Comment actions Permalink

confirming the same issue with 755

0
Comment actions Permalink

Hello,

Fixed in the next build. I was fixing another problem and accidentaly introduced
this bug.

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


DK> In so far as NUnit runs my unit tests successfully, and R# Unit Test
DK> runner doesn't, I consider this functionality broken in this build.
DK> It doesn't find the (app).config and any dependencies that aren't
DK> dll files (i.e. marked as "Content" in the .csproj file)
DK>


0
Comment actions Permalink

.. and 756!

.. so now I can't use Resharper Unit testing at all becuase the licence has expired on the last build that worked (Build 748).

Anyone know of a hack so that I can continue to use Build 748? I need to have the licence stuff disabled or extended?

Dax

0
Comment actions Permalink

:) cool,
thx a lot!
Clemens

0
Comment actions Permalink

Confirming fixed in build 761 after re-install.

0

Please sign in to leave a comment.