Can't Run Unit Tests in R# 4.0

I installed Build 804 and was initially able to run unit tests normally. For no apparent reason, running unit tests from R# stopped working. I created a new project with 1 class that has 1 simple unit test. I tried running and debugging using the side button in the source code, the Solution Explorer, and the Unit Test Explorer windows. This creates new unit test sessions, but these sessions never terminate, nor do the debugging sessions ever hit the first line of my code. I tried installing build 809, but still encounter the same issue.
Unit tests run fine from the NUnit GUI.

6 comments
Comment actions Permalink

I found a workaround. R# seems to get stuck while building the project. If I set the build settings to "Never Build" things work as expected, if they are "Always Build" or "Automatic" the tests aren't run.
My machine has been in use for a few days, with a clean VS 2008 installation with no other add-ins. I tested on a small new project, so it's unlikely that something weird in my project is disrupting the build.

0
Comment actions Permalink

Hello Ross,

Please can you try latest nightly builds and tell us if it is reproducable?
I can't repro it.

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


IR> I found a workaround. R# seems to get stuck while building the
IR> project. If I set the build settings to "Never Build" things work as
IR> expected, if they are "Always Build" or "Automatic" the tests aren't
IR> run. My machine has been in use for a few days, with a clean VS
IR> 2008 installation with no other add-ins. I tested on a small new
IR> project, so it's unlikely that something weird in my project is
IR> disrupting the build.
IR>


0
Comment actions Permalink

I see the same behavior in build 810. I just noticed that it is intermittent- after upgrading, one of the times I tried this out, I was able to set build settings to Automatic or Always Build, and have it work properly. However, most of the time it still fails as described- Automatic or Always Build will get stuck, while Never Build works. I've attached a screenshot showing what the session looks like when it gets stuck.



Attachment(s):
test.GIF
0
Comment actions Permalink

I can't run my unit tests either, using R# build 810. I am going to go back
to one of the previous build so I can run my unit tests.

Gabriel Lozano-Moran


0
Comment actions Permalink

I was running tests all day yesterday using build 809. I'll upgrade to the latest nightly once I get into the office today and will try to reply back with my results. In the meantime, I wonder what it is about the original author's tests/system/etc. that would cause the problem on various builds including 809 while I have had no problems with my tests using 804, 805, 809, etc.

0
Comment actions Permalink

I just tried build # 809 and the test run fine again. So a bug must have
been introduced in # 810.

Gabriel Lozano-Moran

"Jeremy Gray" <no_reply@jetbrains.com> wrote in message
news:21052476.39171212070941219.JavaMail.jive@app4.labs.intellij.net...
>I was running tests all day yesterday using build 809. I'll upgrade to the
>latest nightly once I get into the office today and will try to reply back
>with my results. In the meantime, I wonder what it is about the original
>author's tests/system/etc. that would cause the problem on various builds
>including 809 while I have had no problems with my tests using 804, 805,
>809, etc.


0

Please sign in to leave a comment.