RS 4 shortcuts don't work

Hi there,

I just did a clean install of VS2005 and ReSharper 4. Setup went smoothly and everything seems to work, except keyboard shortcuts. I've tried setting and resetting both shortcut schemes - nothing. ReSharper just doesn't override Visual Studio's shortcuts.
Can someone give me a clue, what could be wrong with it?

Thanks in advance,
Alex

5 comments
Comment actions Permalink

Hello Alexey,

Can you see ReSharper commands in Visual Studio Options / Keyboard list?
Can you set shortcuts manually for those commands?

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


IR> Hi there,
IR>
IR> I just did a clean install of VS2005 and ReSharper 4. Setup went
IR> smoothly and everything seems to work, except keyboard shortcuts.
IR> I've tried setting and resetting both shortcut schemes - nothing.
IR> ReSharper just doesn't override Visual Studio's shortcuts.
IR>
IR> Can someone give me a clue, what could be wrong with it?
IR>
IR> Thanks in advance,
IR> Alex


0
Comment actions Permalink

Hello Ilya,

yes, I can see them. I assigned Alt+Enter to ReSharper.QuickFix and it works now.

Alex

0
Comment actions Permalink

Hello,

Possibly, some other VS extension is preventing R# from setting its shortcuts,
or rather a nonstandard VS configuration.

Please note that installing or repairing any other VS extension will probably
wipe out all of R# keyboard assignments. This is a limitation of the current
Visual Studio API. Hopefully, Dev10 will be an improvement.

Can you confirm that R# Options | Environment | General does not set the
shortcuts when you click the Apply button in the middle of the dialog?


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Hi Serge,

I just got the problem resolved. Not sure what solved it, though.
That Apply button didn't work for me previously. Then I have set some shortcuts manually. Today I tried pressing it again, just before replying you that it doesn't work and I got a new popup saying something like "your keyboard schema is readonly". I did't get this popup before. So I changed the keyboard schema in VS Options and tried setting the shortcuts again. It worked!

Thanks a lot, Serge.

Just BTW, the problem surely wasn't in another VS extension as I don't have any except R#.

Thanks again.
Cheers,
Alex

0
Comment actions Permalink

Hello,

That was a common problem in old VS versions, like VS 7.x (2003 for instance),
but back then the warning message would pop up as expected. We haven't seen
the readonly issue lately, though. Thank you for the information.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.