Unit tests do not run in Unit test session window

Hi Guys

I'm new to Resharper and could use  a little help.

Unit tests do not run in Unit test session window. They start and just exit before excuting any code at all, and show a grey icon to the left of the test. I think this means that it didn't run.

The project builds just fine and the tests run in VS2008 test view OK.

I have version 4.5 build 1237 running on XP sp3.

They have been ruuning just fine up to now but have now stopped!

I have tried reinstalling Resharper to no avail.

Any ideas?

Thanks in advance

8 comments

Could you, please, provide some details, when they start failing?

Or, maybe, you have small example solution on which this bug is always reproducible?

0

Thanks Victor

This test:

[TestMethod]
        public void TestMethod1()
        {
            int i = 5;

            Assert.AreEqual(5, i);
        }



runs ok in a another project on the same machine, so it doesn't seem that it is a break in Resharper. But in the specific project I am working on the test is always skipped, showing the grey icon.

But in the VS2008 test view it runs fine as do all the others. The projects builds OK.

Resharper  briefly shows "pending" beside the test then stopsm having skipped it.

The icon on the session tab is also grey.

All tests are unconditionally skipped.

Are there any settings that cause tests to be skipped?

Any ideas anyone?

0

Do use Test Run Configuration when running tests in this project?

0

Hi Victor

I dont use Test>Run> Config. That runs the test in the VS2008 test view which works fine .

I'm using the resharper icon beside the test.

Any test run in the resharper session window is skipped. Period.

Test run in the VS2008 test view run as expected.

Any ideas anyone?

0

Hi All

For the record this resolved the problem:

I deleted the directory _ReSharper.SMS-LMS and the resharper .user file in the same directory.

This cleared up the problem

Thanks.

0

I have the same problem. No tests want's to run, they all just turn grey.

I've deleted the _ReSharper.<project_name>-directory and <project_name>.4.5.resharper.user but it doesn't seem to help :-( Any other ideas?

0

Do your Unit tests run in the stock VS2008 test view?
If not there might be a build problem other than that I found that if I created a new project and created a basic test it ran OK.
For me it was project specific, and I dont have any other suggestions as I'm new to Resharper.

However there is a Test results folder and mine gets *very* full. It might be worth deleting that to see if it helps.

I assume you have the magic trick of Clean/Rebuild.

Support is a bit hard to find here!!

0

Thanks for your reply. I'm using NUnit, so I can't use the VS 2008 test view.

I figured out that my problem also was project specifc so I started copying the tests one by one to a new project. When I copied App.config the tests started to not run. It turned out that there was a syntax error i App.config... great way of notifying me :-(

But it works now - great :-) Thanks!

0

Please sign in to leave a comment.