VS2008sp1 R#4.5.1231 Performance issues while editing -- suggestions

I'm having trouble actually typing in the editor with R# its constantly
freezing and pausing for 30 seconds or more. I'm spending more and more
time with the R# disabled so I can just see what I'm typing, the type ahead
problem is so bad I don't even bother recommending co-workers try this
version of R# anymore. The problem seems to be exponentially worse as the
file size increases. I know aspects of this are more due to VS2008 editor
or they wouldn't have bothered to promote the new editor improvements in
VS2010, but i have work to do before 2010.

- A "nice level" slider for file parsing so I can make it use less than 100%
CPU
- File/Solution parsing should be paused or very nice when I'm typing or
debugging,
- Wait till the user is idle before starting a file parse for larger files
that cause the editor to freeze
- Parsing performance seems to really suffer if the IDE has been running for
a while forcing a double GC seems to help a bit.
- last resort ... a one click enable/disable of all parsing. Instead of
(Resharper -> Options.. -> Settings -> Enable code analysis -> Enable whole
solution analysis -> OK -> OK )


4 comments

Have you tried closing all VS instances, deleting ALL Resharper caches, and
restarting?

What types of files are you experiencing this in? Just in Website
solutions? Editing ASP.NET code?

I don't experience anything like this, and I assure you, neither do most
other people, or nobody would use ReSharper.

There is something wrong on your system, and hopefully it is something that
can be fixed, but more details are needed.


"MWalsh" <MWalsh@patriotllc.com> wrote in message
news:h2jj35$jfl$1@is.intellij.net...

I'm having trouble actually typing in the editor with R# its constantly
freezing and pausing for 30 seconds or more. I'm spending more and more
time with the R# disabled so I can just see what I'm typing, the type
ahead problem is so bad I don't even bother recommending co-workers try
this version of R# anymore. The problem seems to be exponentially worse
as the file size increases. I know aspects of this are more due to VS2008
editor or they wouldn't have bothered to promote the new editor
improvements in VS2010, but i have work to do before 2010.

>

- A "nice level" slider for file parsing so I can make it use less than
100% CPU
- File/Solution parsing should be paused or very nice when I'm typing or
debugging,
- Wait till the user is idle before starting a file parse for larger files
that cause the editor to freeze
- Parsing performance seems to really suffer if the IDE has been running
for a while forcing a double GC seems to help a bit.
- last resort ... a one click enable/disable of all parsing. Instead of
(Resharper -> Options.. -> Settings -> Enable code analysis -> Enable
whole solution analysis -> OK -> OK )


0

Hi there,

I've been experiencing a serious slowdown with asp.net aspx pages and web.config file editing with the latest builds of resharper 4.5.1, in the early builds this problem wasn't there.

I noticed a slowdown probably in the last 3 weeks and I have cleared my cache and all. What happens is you type say 10 characters and like probably only 3 characters come up 1 at a time after a short delay
e.g. Typing <add key="test" would come out as:

< (pause)
a (pause)
d (pause)
d (pause)
at this point you have to retype the rest (key="test") because it loses it in the buffer somehow

Not sure what is causing the problem but when resharper is off the problem goes away

Note I initially had problems with asp.net files (aspx) and the problem went away when I cleared the cache, but after a few hours of using the editor again the slowdown came back, but in the case of the web.config the problem never goes away it still has the problem.

The last build I've tried is: 1267

Rob

PaulB wrote:

Have you tried closing all VS instances, deleting ALL Resharper caches, and
restarting?


What types of files are you experiencing this in?  Just in Website
solutions?  Editing ASP.NET code?


I don't experience anything like this, and I assure you, neither do most
other people, or nobody would use ReSharper.


There is something wrong on your system, and hopefully it is something that
can be fixed, but more details are needed.

0

Build 1267 is quite old. There we performance improvements in late build 127-something. I would recommend installing the most recent one from http://www.jetbrains.net/confluence/display/ReSharper/ReSharper+4.5+Nightly+Builds

0

Hi there,

The web.config file has certainly been fixed but editing some other files still has big problems as I have outlined here:

http://www.jetbrains.net/devnet/message/5242233#5242233

I'm not sure what is causing this problem

Thanks for the reply

0

Please sign in to leave a comment.