Latest R# 5 nightly builds are unusable on Visual Studio 2008

For more than a week now, I have to revert to R# 4.5 because the nightly builds make my visual studio 2008 with SP1 unusable. When I create a new Console Application or Web Application and start it in debugging mode, there is some thread blocking everything. I can start but the Console Application or Web Application don't appear. Furthermore, Visual Studio 2008 IS RESPONSIVE but there is a foreground thread blocking it.

4 comments

I also see this behaviour with the same set-up, but only when I run WPF applications in Debug mode by hitting F5. If I build the application before hitting F5, the error does not occur. It appears that there is an issue when R# initiates the build process. Could that be the foreground process blocking VS?

0

I too have this problem. It seems only to occur when there are unsaved files, however, it might as well be the fact that ReSharper initiates the build - that actually seems to make sense.

0

I was able to fix this so far:

1. I removed AnkhSVN
2. I removed GhostDoc
3. I removed Microsoft StyleCop
4. I installed the latest R# 5 nightly build
5. I installed AnkhSVN
6. I installed GhostDoc

The only thing I have not installed yet is Microsoft StyleCop. At least now I can continue to work but this fixed it for me.

0

I experience the same issue, but uninstalling and reinstalling all plugins didn't help

0

Please sign in to leave a comment.