R#5 Startup hang on VS2008

I have an intermittent, though frequent, problem with VS2008 hanging early in the startup process when R#5 is installed (it's been going on for a long time with lots of different nightlies).

I cannot say 100% certain that it's R#'s fault (I have other add-ins installed too), but the problem did go away when 4.5 was reinstalled for a while.  The hang seems more likely to occur if you interact (e.g. mouse-over the toolbars) with the VS window while it's starting up - if you leave it alone until it's finished starting, there seems to be less of a problem.    I always have multiple instances of VS running, I don't know if this is related.  Anyone else seen anything like this?

I have taken a procdump dump of the most recent hang - it's only about 5MB zipped (like I say, it's quite early in startup) - should I send this to one of the JB guys by email, or should I file a bug and attached it - can I attach a 5MB zip file to a bug report?

TIA,

Will

2 comments
Comment actions Permalink

Hello Will,

Thanks for taking a dump, please send it to me, orangy at jetbrains by email

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


WD> I have an intermittent, though frequent, problem with VS2008 hanging
WD> early in the startup process when R#5 is installed (it's been going
WD> on for a long time with lots of different nightlies).
WD>
WD> I cannot say 100% certain that it's R#'s fault (I have other add-ins
WD> installed too), but the problem did go away when 4.5 was reinstalled
WD> for a while.  The hang seems more likely to occur if you interact
WD> (e.g. mouse-over the toolbars) with the VS window while it's
WD> starting up - if you leave it alone until it's finished starting,
WD> there seems to be less of a problem.    I always have multiple
WD> instances of VS running, I don't know if this is related.  Anyone
WD> else seen anything like this?
WD>
WD> I have taken a procdump dump of the most recent hang - it's only
WD> about 5MB zipped (like I say, it's quite early in startup) - should
WD> I send this to one of the JB guys by email, or should I file a bug
WD> and attached it - can I attach a 5MB zip file to a bug report?
WD>
WD> TIA,
WD>
WD> Will
WD>
WD> ---
WD> Original message URL:
WD> http://www.jetbrains.net/devnet/message/5254110#5254110


0
Comment actions Permalink

orangy wrote:

Thanks for taking a dump, please send it to me, orangy at jetbrains by email


On it's way.

Cheers,

Will

0

Please sign in to leave a comment.