Getting weird 'cannot resolve symbol' errors

I am getting some head-scratching errors on simple html elements with id specified.

For example, on something like

<div id="wrap" class=2col">

I am getting: 'cannot resolve symbol "wrap"

This happens to be in the content section of an master page.


Still getting this on later builds. "Cannot resolve symbol" on certain div elements in ASPX content files inside master pages...

There aren't server controls. Just simple <divs> with id.


Still getting this in the latest build, along with the Ambiguous Reference errors all over Web.config.

Hard to believe it's almost ready for Beta, with most of the ASP.NET features still broken as they are.


It's dead weird. Could you send me a working sample for investigation. Thanks in advance.
my direct e-mail is qx [at] jetbrains [dot] com


Sent. Thanks for looking into it.


Thanks a lot for the sample. We're out of the city for several days, I'll fix it as soon as we're back.


Fixed. Try tomorrow's nightly.


MOSTLY fixed it appears, but not totally.

I'm still getting "cannot resolve synbol" inside some templated controls. For example, in the <LayoutTemplate> and <ContentTemplate> of the CreateUserWizard.


Most likely, I've fixed the problem. Please, try the upcoming nightly. If not,could you create a sample for me.


Thought I'd mention, I'm still seeing some of these "cannot resolve symbol" errors on pure HTML tags with ids (not server controls).

Not sure why ReSharper woul be still be complaining about not being able to resolve a symbol that isn't actually a symbol, since simple HTML tags don't cause any fields to be generated in the designer.

Andrey Serebryansky

Hello Lee
     Which build are you using? Could you please send a repro sample to andrew dot serebryansky at jetbrains dot com or to sergey dot coox at jetbrains dot com? Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

"Develop with pleasure!"


We are downloading each build as it is released (in hopes that the error might be fixed in one of them). This has been happening on every build we have tried.

This is an ASP.NET 4.0 project, and we're using VS 2010 Professional Beta 2.

Unfortunately, I haven't been able to repro this with a small sample. However, I can point you to our project (it is on CodePlex) where you can download it and find it quickly for yourself by turning on solution-wide analysis.

It is a fairly small download.

Unzip the download, load it into VS2010, and you should see "Cannot resolve symbol 'submenu'" in \admin\CyclemaniaAdmin.Master.

The markup that is affected is as follows:

<ul id="submenu" >



We appreciate your feedback. The corresponding JIRA request has been created,
and you are welcome to monitor its status at

Kirill Falk
JetBrains, Inc
"Develop with pleasure!"


The only thing left is the incorrect parameter number on several DeleteUser method references. I cannot understand where the userName comes from



You will notice that those methods (GetUserCount and DeleteUser) are being used by ObjectDataSources.

The DeleteUser method takes a userName parameter. The userName parameter is supplied by the lvUsers.DataKeyNames property. You will see that in lvUsers, there is a property DataKeyNames="UserName".

The Delete method of an ObjectDataSource always grabs the key it needs from the bound control's DataKey. So, for example, if I go to delete user "Joe", it will look at that data item, pick out it's UserName property (which of course would be "Joe") and automatically pass that to the Delete method.

Because of that, you cannot specify the delete parameter declaratively. So, even though DeleteUser takes one parameter, there are 0 parameters in the declarative markup, This makes Resharper think there is a missing parameter, and report a "INCORRECT_PARAMETER_NUMBER" error.

It is the same thing for GetUserCount. In an ObjectDataSource with paging enabled, the SelectCountMethod must accept whatever declarative parameters are specified by the <SelectParameters> collection (even if they are not used in the method). Here, the GetUserCount method accepts the "filter" or "status" parameters. No problem there. However, the SelectCountMethod cannot accept the implicit startRowIndex or maximumRows parameters. That would make no sense, as the SelectCountMethod is supposed to return a TOTAL count of ALL records.

However, ReSharper thinks that GetUserCount should be accepting 3 parameters (filter, startRowIndex, maximumRows) or (status, startRowIndex, maximumRows), and again is raising the "INCORRECT_PARAMETER_NUMBER" error.

Does this make sense?


Thanks a lot for clarification of DeleteMethod params. I've discovered that I mislooked the SelectParameters collection for SelectCountMethod.
I gonna fix it ASAP.


Thanks, keep me posted on it. Look forward to getting the fixed build.


Wow, what a shame. It looks like the "cannot resolve symbol" errors have now returned with the VS2010 RC builds.

Getting them all over the place, even on Eval() statements in databinding expressions. That's not good. Can't really bind data to the UI in ASP.NET without Eval().


Holy crap!

What exactly is not resolved? It would be great to have sample for investigation. Thanks in advance.


I think this may have been an issue on my end with old temporay compiler files generated by the Beta 2 release. Deleted them, and not reporting errors now.

Sorry about that, guess I spoke too quickly.


Thanks for good news


It seems to be some years back - but I do now have these allover some of the solution I'm working on.

for example:

    <form id="Aufhebung_Detail" method="post" runat="server">
        <bc:BreadCrumbs ID="BreadCrumbs1" runat="server" Text="Aufhebung detail" OnClick="BreadCrumbs1_Click">
        <style:Header ID="PageTitel" runat="server" Text="Details"></style:Header>

the id is reported as such - 46 error in 46 files. the solution compiles and runs fine. It is a ASP.NET using Webforms. It turns out that it is always the same situation: <form id="someName"

Working on a virtual machine running windows Server 2008 r2 and Visual Studio 2015 pro (latest SP); R# is latest release as I - just as Lee - always update hoping to have this fixed.

My workaround is to just ignore those specific errors and that's fine for me. Still wanted to report to enable you getting rid of those incorrectly reported errors.







normally the id must be present in C# code behind as a field.

protected global::System.Web.UI.HtmlControls.HtmlForm Aufhebung_Detail;

Could you please create a sample for us to investigate.


Please sign in to leave a comment.