XAML editor refresh problems

When I resize the xaml editor in VS 2008 and I have resharper running, the newly exposed area of the editor does not repaint properly but shows a copy of what was there before. I have attached a screen shot to highlight the problem.

I'm running on 64 bit Vista so graphics card drivers may be an issue, but when I switch resharper off the editor re-paints on re-size properly.

R# version is 4.1.933.3

Regards

Steve



Attachment(s):
xaml_editor.jpg
6 comments

Hi Steve,

As I can see I am not the only one having the rendering issue problem.
Take a look at my thread which remains unanswered : http://intellij.net/forums/message.jspa?messageID=5224274#5224274

I also sent this issue to support on 9.8.2008 but they say they were unable to reproduce it and that they need to set up a Vista x64 environment.
I insisted a lot with the issue but I never received feedback again :(

If I uninstall Resharper everything works fine. Also in other developers machines with Vista x32 or XP x32 everything works fine.
Hope the Resharper team can get a Vista x64 environment to test and solve the issue !.

Claudio.

0

Hi Claudio

I have an ATI Radeon X1300/X1550 graphics card and I think the problem lies in that area - something to consider you JetBrains support guys when you are setting up your Vista x64 machine.

It's a bit remiss that this still hasn't been sorted out 2 months down the line from your original query. More and more people are developing under Vista x64. Come on JetBrains people - any idea when this will be looked at?

Cheers

Steve

0

Steve,

I totally agree with you ! JetBrains should take a look at this issue
2 months ago, support told me (I have the email) that they were waiting for a Vista x64 environment to test it. That was on Thursday and they were expecting to get it on next Monday.. 2 months later and still no answer..is it so difficult to get a Vista x64 environment ?

In my case I was evaluating ReSharper and due to this issue we (6 developers where I works) finally didn't buy it..

Thanks,
Claudio.

0

Guys!

We tried to investigate the problem but no luck   The fact is that the problem is repeatable on x64 only with R# installed (even if it is disabled). We'll try to do our best to cope with the problem. The corresponding JIRA issue is http://www.jetbrains.net/jira/browse/RSRP-105573

0

This bug still exists on 64-bit Windows 7, even in the latest build.

While 64-bit Vista may have been rare and therefore a low priority, 64-bit Windows 7 is being pushed heavily by Microsoft.  Even low-end laptops are being sold with 64-bit Windows 7 installed. 64-bit Windows 7 will soon become a common development environment.

This bug is serious enough that it would have dissuaded me from purchasing Resharper had I encountered it while evaluating the product.

0

Hi,
i have the same Problems with Windows 7 Professional x64, Visual Studio 2008 and ReSharper 4.5 & 5...I hope you'll fix this problem soon...

0

Please sign in to leave a comment.