Missing color scheme settings in Tools->Options->FontsAndColors

Hello,

I applied dark color scheme (VS2008) and now namespaces and some other colors are now unreadable. In 4.5 I could go to Tools>Options>Fonts And Colors and there were a lot of Reshareper* entires I could adjust.

I tried to repair installation but this did not help (it did help when I had similar issue with R# 4.5).  Is there any way I could change color settings in R# 5 EAP, or is this a know issues with beta release?

Thanks for great tool, guys and gals.

10 comments

I have a somewhat similar issue. VS2008 works just fine, as it did in R#4.5. VS2010, however, does not have have R# coloring (yes, i do have "Color Identifiers" turned on). What's more, it does not have that list of "ReSharper *" items in "Fonts an Colors". Is this just because it is still an early release of R#, or should I have identifier coloring? In which case, is there anything I can do to make it work? I tried reinstalling R#, repairing it, resettign VS2010, repairing it as well. Nothing helped.
Thanks in advance.

0

I have tried to import the color scheme I exported from my dev box that runs corp licensed R# 4.5. The import was sucessful and I can see the fixed color scheme that was created with v4.5.

The color scheme persists until I open Fonts and Colors dialog and press OK to dismiss it (without changing anything) and then close and reopen VS.  

0

They were included in an earlier nightly build, but apparently not
anymore. They are also missing from latest build 1528.

0

I can verify this issue--the "ReSharper" highlighting styles have been
missing from the "Fonts and Colors" panel in the 5.0 EAP.  I was able to get
most of my color scheme restored by importing an old .vssettings file, but
my settings for the current line background aren't getting applied.  I'd
really like to be able to configure the R# highlighting styles again.

Cheers,
Mike

"Rouslan Grabar" <no_reply@jetbrains.com> wrote in message
news:25588389.173541257271694150.JavaMail.clearspace@app8.labs.intellij.net...

Hello,

>

I applied dark color scheme (VS2008) and now namespaces and some other
colors are now unreadable. In 4.5 I could go to Tools>Options>Fonts And
Colors and there were a lot of Reshareper* entires I could adjust.

>

I tried to repair installation but this did not help (it did help when I
had similar issue with R# 4.5).  Is there any way I could change color
settings in R# 5 EAP, or is this a know issues with beta release?

>

Thanks for great tool, guys and gals.

>

---
Original message URL:
http://www.jetbrains.net/devnet/message/5248855#5248855


0

Build 1529 seems to be fixing the missing colors issue. Thank you!

0

Mine are still missing.  Did you do anything other than run the new MSI?

Thanks,
Mike

"Rouslan Grabar" <no_reply@jetbrains.com> wrote in message
news:1637065.184461257493707836.JavaMail.clearspace@app8.labs.intellij.net...

Build 1529 seems to be fixing the missing colors issue. Thank you!

>

---
Original message URL:
http://www.jetbrains.net/devnet/message/5249171#5249171


0

Hi Mike,

Unfortunatelly, on my laptop that runs win7, the latest build 1529 has the same issue. I tried everthing - installing, reinstalling, devenv.com /setup, etc without a sucess.

The devbox I installed the latest build on earlier today is a  Windows 2003 R2 and it previously had v4.5 installed, so the R# did an upgrade and the Resharper color options were in place. Maybe it's "clean install" problem?

0

I'm having the same issue on two boxes. The first is an xp box that I upgraded resharper from 4.5.1 to 5.0 The second box was a clean install of win7 and resharper 1529. No color settings for either box.

For the first box I was able to get the settings back by importing a colleague's font and color settings (who did not install 5.0). Of coarse if more settings were introduced, I wont see them.

Is there an issue set up for this yet?

-eric

0

I've added a issue to the tracker
RSRP-131987

0

I had a similar issue and had someone comment with a fix.  It might apply to the problems you are having here.

http://www.jetbrains.net/devnet/message/5260945#5260945

0

Please sign in to leave a comment.