Is there a setting to keep strings from being split when pressing 'Enter'?

I noticed in the R# 6 build that I'm using (6.0.2145.245) that when I have a line like this:

var myString = "Some text here";

If my cursor is, say, right after the "e" in "Some", and I press Enter, the statement changes to this:

var myString = "Some" +
    " text here";

Is there a way to disable this behavior?  I'm not seeing it in the R# options dialog.

Normally, this would be a nice feature, since it would easily allow you to break strings into multiple lines of code without having to type all those quotes and plusses yourself.  However, I am also using ViEmu, a Visual Studio extension that emulates Vim keybindings.  When in "normal" mode in Vim/ViEmu, the Enter key is used to execute commands, not insert a CR/LF.  So, when I try to execute a save command (by typing ":w Enter"), if my cursor is over a string, the string gets split, even though that's not at all what I intended.

If there is not an option to disable this, I will put in a feature request to have it added.

1 comment

Hello Brian,

I've added a bug-report at http://youtrack.jetbrains.net/issue/RSRP-262770
and we will check if and how this problem can be addressed. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I noticed in the R# 6 build that I'm using (6.0.2145.245) that when I
have a line like this:

var myString = "Some text here";

If my cursor is, say, right after the "e" in "Some", and I press
Enter, the statement changes to this:

var myString = "Some" +
" text here";
Is there a way to disable this behavior?  I'm not seeing it in the R#
options dialog.

Normally, this would be a nice feature, since it would easily allow
you to break strings into multiple lines of code without having to
type all those quotes and plusses yourself.  However, I am also using
ViEmu, a Visual Studio extension that emulates Vim keybindings.  When
in "normal" mode in Vim/ViEmu, the Enter key is used to execute
commands, not insert a CR/LF.  So, when I try to execute a save
command (by typing ":w Enter"), if my cursor is over a string, the
string gets split, even though that's not at all what I intended.

If there is not an option to disable this, I will put in a feature
request to have it added.

---
Original message URL:
http://devnet.jetbrains.net/message/5302518#5302518



0

Please sign in to leave a comment.