Unintentional autocomplete in lambda expressions in Razor views

When typing a lambda expression in a Razor view, ReSharper autocomplete does not behave the same as it does within a C# file, in particular when using the spacebar.  For example, say I wanted to create a label in Razor like this:

@Html.LabelFor(m => m.FirstName)

When I try to type the space between the first "m" and the "=>", "m" gets autocompleted to "Model" or something else.  This does not happen when typing lambdas in a C# file; autocomplete does not fire when the spacebar is pressed when typing a lambda parameter.  This makes it rather annoying to type these expressions in Razor, I have to hit "Esc" after I type the name of the lambda parameter.  

Even if it takes a while for you guys to bring the Razor completion behavior in line with what was already there with C#, I could solve this by simply disabling Space as a completion key.  Is there any way to keep space from autocompleting in the ReSharper options?

Please sign in to leave a comment.