Cannot Resolve Area Symbol in Resharper 6.1 RTM

Hello,

i'm using resharper 6.1 RTM, but areas in my application is not recognized, for example, in Url.Action("Index","Home",new{area="Admin"), Admin area name is not recognized.

Cannot Resolve Area Admin!!!!

Thank you.

9 comments
Comment actions Permalink

Same here, just upgraded to 6.1 and now wherever I use an area, Resharper thinks its an error.

0
Comment actions Permalink

Would love to know what the timetable is for a fix for this, or for a workaround at least. Rolling back to 6.0 for now.

0
Comment actions Permalink

On 19.01.2012 0:29, Matt DiTrolio wrote:

Would love to know what the timetable is for a fix for this, or for a workaround at least. Rolling back to 6.0 for now.


Fix will be included in ReSharper 6.1.1.
EAP of 6.1.1 is already started http://confluence.jetbrains.net/display/ReSharper/ReSharper6.1.1Nightly+Builds

0
Comment actions Permalink

I'm also getting this issue - any update on the fix? That link does not work?

0
Comment actions Permalink

Not quite correct -- the latest nightly build still marks the areas as invalid in full solution analysis.

0
Comment actions Permalink

On 09.02.2012 2:57, Karl Mayer wrote:

> Not quite correct -- the latest nightly build still marks the areas as invalid in full solution analysis.

What do you mean? In open editor there is no error, but they are in solution analysis window?

0
Comment actions Permalink

In my case, the solution-wide analysis in the bottom-right corner of Visual Studio 2010 was still reporting an error for each Area reference used, even after I turned it off and back on.  However, I noticed that after I visited the location of each error, the solution-wide analysis counter would deincrement by 1.  So perhaps it's just cleaning some cached data up.

0

Please sign in to leave a comment.