Build 65 Issues

I installed build 65 this morning into VS2010 ( Win7,  Quad Q9550, 8GB Ram ).

Solution contains 10 Projects:  6 Class Libraries, 2 ASP.NET MVC3 (Razor) sites, and a Database Project.

First off - all of the Resharper colors had to be manually reset - the color information is different than prior builds making it impossible to import the correct colors.

Preformance was very bad - hangs in VS on the simplest things, like selecting the editor, attempting to navigate around inside the editor, navigation to other classes via Navigate To... functionality.  Plus each keystroke was taking anywhere from .5 sec to 1.5 sec to register.

Also noticed that the Managed Memory was increasing at about 1MB every 10 minutes.

Installed Extensions:

BugAid
CommandImage
Editor Guildelines
Editor Guildelines UI
Javascript Parse
JScript Brame Matching Extension
JScript Editor Extensions
JScript IntelliSense Para Extension
JScript Outlining Extension
JScript Work Highlighter Extension
NuGet
PowerCommands
Productivity Power Tools
Regex Editor
Spell Checker
Team Foundation Sidekicks
Text Sharp
VersionInfo
VSCommands
WoVS Default Browesr Switcher

5 comments
Comment actions Permalink

Regarding the colors: They are stored in the registry under [HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\<Version>\FontAndColors\{A27B4E24-A735-4D1D-B8E7-9716E1E3D8E0}] (<Version> is 10.0 for Visual Studio 2010 and 11.0 for Visual Studio 2012 RC). In VS 2012 RC they are stored in a different location since build 65, which is [HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\11.0\FontAndColors\{75A05685-00A8-4DED-BAE5-E7A50BFA929A}].

As R# oftly loosed my color settings while installing EAP builds i had exported this registry hive and import it back again each time my color settings are lost. So i just had to change the key in the .reg file and voila, my colors where back.

I don't know if this will work in VS 2010 too because VS 2012 RC has two different UI themes (light and dark) and so the different key is nesseccary. Anyway you may have a chance to get yout colors back if  they are saved in the [HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\11.0\FontAndColors\Cache\{A27B4E24-A735-4D1D-B8E7-9716E1E3D8E0}] hive (all relevant keys starts with "ReSharper"). Then you just have to export the hive, rename the key and import it back again.

If you save your Visual Studio settings via "Tools / Import and Export Settings" your R# color settings are saved too. You can save your color settings only by deselecting all but "Options\Environment\Fonts And Colors".


Regards
Klaus

0
Comment actions Permalink

Similar problems here with 65 and 66.

Only difference: slower cpu , less ram (Dual core E6700, 4GB) and NO installed extensions (vs is slow enough as it is).

Exceptionally bad slow down: Pressing F12 results in 3/4 seconds of 50% cpu (one core) before the list appears, and writing in the dropdown to reduce the list entries is also very slow with 50% cpu usage.

Only somewhat bad slowdown: smart completion is sometimes slow (50% cpu usage for 1/2 seconds) - when completing class fields for example.

Moving back to version 63. I don't know if I've been lucky, but in 10 years of using JetBrains products it's the first time I've had to return to a previous version after installing a beta :|

Note: after reinstalling version 63, all the slowdowns have gone away.

0
Comment actions Permalink

there are issues that r# is showing an error that mscorlib reference is missing I guess this is the source for the slow down see other thread "build 65 broken"

0
Comment actions Permalink

Hello All
     Thank you very much for feedback! There are certain problems with builds 65 and 66, so we've marked them as 'Broken'. We're doing our best to resolve these problems as soon as possible.

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

That sounds good. I want to play with the new icons :D

0

Please sign in to leave a comment.