[Build 87] Deadlocks in smart code completion


Build 87 seems broken with vs2010: in less than one hour since installed deadlocked three times when invoking smart code completion (no cpu, vs doesn't respond).

Edit:

Cleared the cache the second time and vs2010 still deadlocked after 5 minutes.

example lock:

_isReadOnly = authorizationService.IsAuthorizedForEntity(typeof(TrfDeliveryV).Full<cursor here>);

Edit again:

It doesn't happen always. After restarting vs the autocompletion worked, but after a little while... deadlock.

7 comments
Comment actions Permalink

Another deadlock: reverting to build 86.

0
Comment actions Permalink

FYI
I installed Build 87 this morning and Visual Studio has hung on me 2 times so far
(have to close with taskbar)

JetBrains ReSharper 7.0 Beta Full Edition
Build 7.0.87.126 on 2012-07-13T03:12:30

Licensed to: EAP user (expires 7/15/2012)
Plugins: none
Visual Studio 11.0.50522.1.

0
Comment actions Permalink

Yep, same here. Just got 87 and got stuck for around five times already on a simple single .cs file console project with a single Main method (though containing few lambdas with closures). I keep killing and restarting my VS. Thank you, MS overlords for recovery feature.
Resharper people, let us know if you need a dump file. I'd rather not attach it here: with heap even compressed it's still >200MB. My R# build is 7.0.87.126 as well.

0
Comment actions Permalink

Build 88 seems to have this issue solved.

0
Comment actions Permalink

Hello Alex
     Thank you for this information!

Carlos and Ken,
     Could you please confirm if this problem is fixed for you in build #88?

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

It is working great now for me with the latest build.  Thanks for fixing.

0
Comment actions Permalink

Seems fixed for me too with todays build (89).

Tx.

0

Please sign in to leave a comment.