8 comments
Comment actions Permalink

Hi Calin,

Could you please describe this issue in detail? Is it reproducible on every solution with tests, even new and just created ones?

Thank you!

0
Comment actions Permalink

It is not reproduceable using simple test with throw exception.

It is failing consistently on the same test assemblies. 10 assemblies out of 17 are failing in what seems to be the exact way according to the stack.
Capture.PNG
When debugging the unit tests no errors happen in our code. The above stack trace is from the first error before running any of our code. After this all tests are executed, and pass, resharper shows the greent tick for all of them and then it never ends execution.
The runner tasks are "hanging":
Capture1.PNG
If we kill those tasks then Resharper wakes up and looks as if everything is perfect.

0
Comment actions Permalink

Hi Alex,

I just tried the new EAP and test runner hangs in the same manner. I have a mini dump of the hanging process. Do you want it?

Cheers,
Calin

0
Comment actions Permalink

Hi,

Sure. Any information is much appreciated!  Minidump is nice, as well as we would appreciate a sample solution, which will demonstrate the issue so we can easily reproduce it in our labs.

Thank you!

0
Comment actions Permalink

Minidump attached.

I did not have time to isolate a small sample solution, sorry.

I hope the minidump is enough.

Cheers,
Calin



Attachment(s):
JetBrains.7z.zip
0
Comment actions Permalink

Hello Calin,

Thanks a lot for the info. I've passed the information to the corresponding developer.

0
Comment actions Permalink

Hi Alex,

I just tested the new EAP build and Test Runner still hangs.

Here is the new minidump.

Cheers,
Calin



Attachment(s):
JetBrains TestRunner.7z.zip
0

Please sign in to leave a comment.