Resharper entries are gone in Fonts and Colors VS 2008 settings

In Build 2074 all the resharper settings are gone under the VS 2008 Font and Colors settings in Tools. I installed R# twice. I am using a dark theme in VS and the current line highlighter is so bright I can hardly see the underlying text. I turned off line highlighting. I am glad it's a separate setting inside R#.

For now I am using the ruler from the free SlickEdit gadgets http://www.slickedit.com/products/slickedit-gadgets

7 comments
Comment actions Permalink

Hello abdu,

Please close all instances of Visual Studio and clear the HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\9.0\FontAndColors\Cache
registry key. Let me know if this helps. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

In Build 2074 all the resharper settings are gone under the VS 2008
Font and Colors settings in Tools. I installed R# twice. I am using a
dark theme in VS and the current line highlighter is so bright I can
hardly see the underlying text. I turned off line highlighting. I am
glad it's a separate setting inside R#.

For now I am using the ruler from the free SlickEdit gadgets
http://www.slickedit.com/products/slickedit-gadgets

---
Original message URL:
http://devnet.jetbrains.net/message/5283275#5283275



0
Comment actions Permalink

That worked. Thanks. Although between R# upgrades my current line setting is not remembered. So I have to save VS settings before the upgrade and reload them after the upgrade.

[UPDATE] The installer doesn't seem to touch this registry key. See my reply above about the registry monitor.

0
Comment actions Permalink

This issue happened again in the next upgrade. Can the installer take care of this issue?

0
Comment actions Permalink

Hello,

At the moment ReSharper installer runs all necessary commands in order to
handle fonts and color settings, so this should not happen of course. Could
you please check that the Fonts and Colors entries are lost if you uninstall
and then re-install the same version of ReSharper? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

This issue happened again in the next upgrade. Can the installer take
care of this issue?

---
Original message URL:
http://devnet.jetbrains.net/message/5283771#5283771



0
Comment actions Permalink

The entries are not deleted after uninstalling R#.

When I clear them manually before an install, they still don't show up. I have to clear the cache then they show up.

0
Comment actions Permalink

I am having the same issue with another machine. I fired Process Monitor and captured the events from msiexec. There wasn't a single entry for HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\9.0\FontAndColors\Cache. I don't see how the installer is clearning this registry entry during the installation.

0
Comment actions Permalink

When you say "clear" do you mean delete the Cache key or delete all the keys underneath it? Or something else?

I'm having this problem with R# 8.x.

0

Please sign in to leave a comment.