due to refactoring it is sometimes necessary to "negate" a boolean variable.
For example, imagine I have a class that contains a field called
"_lastWasSeparator". This variable is used to suppress duplicate separators
After a little bit of implementing I figured out that I also want to
suppress single first/last separators. So it would be useful to rename the
variable to "_allowSeparator". Obvisously the meaning of the boolean is now
I think this a very common problem so I would be very pleased if ReSharper
would support it!
Immo Landwerth, Germany