R# 2.0 steals Ctrl+Tab

Keyboard navigation in R# has always been a bit of give and take for me: It is very rich, which I like, BUT it has stolen a few of the VS key bindings that I would have liked to have kept (E.G. CtrlAltB, CtrlAltP, CtrlAltV). I am happy to live with that as R# adds a lot to my productivity as a developer.

I am now starting to use R# 2.0 in VS2003 and one of the first thing I notice is that you have re-assigned Ctrl+Tab.

Ctrl+Tab is a fundamental shortcut that, in just about every windows application, allows navigation to the previous view.

If you can take CtrlTab, how long before AltF4 dissapears into R#? Will Windows be left with any shortcuts of its own? ;)

Seriously, please think long and hard before you release a product that steals very standard keyboard shortcuts.

Also, do you have a "ReSharper 2.0 Default Keymap" document?

3 comments
Comment actions Permalink

James,

It was an error assigning our shortcut to Ctrl+Tab, we will fix it in the
next build. As a workaround You may either use Ctrl+E instead or reassign
Ctrl+Tab in Tools->Options->Keyboard menu

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Just as annoyingly, I seemed to have lost "Shift-Tab" (to decrease indent of
selected text)... and this is even after having reverted back to Resharper
1.5! I can't seem to do anything to get it back. This is VERY annoying, as
I use that keystroke often.

"Sergey V. Coox" <qx@intellij.com> wrote in message
news:dcso99$4pl$1@is.intellij.net...

James,

>

It was an error assigning our shortcut to Ctrl+Tab, we will fix it in the
next build. As a workaround You may either use Ctrl+E instead or reassign
Ctrl+Tab in Tools->Options->Keyboard menu

>

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"



0
Comment actions Permalink

Hello Paul,

sorry for this problem, it has been fixed as well.
To get Shift+Tab back, try to restore the default keyboard mapping, then
copy it, and then activate ReSharper. I think this should help.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Just as annoyingly, I seemed to have lost "Shift-Tab" (to decrease
indent of selected text)... and this is even after having reverted
back to Resharper 1.5! I can't seem to do anything to get it back.
This is VERY annoying, as I use that keystroke often.

"Sergey V. Coox" <qx@intellij.com> wrote in message
news:dcso99$4pl$1@is.intellij.net...

>> James,
>>
>> It was an error assigning our shortcut to Ctrl+Tab, we will fix it in
>> the next build. As a workaround You may either use Ctrl+E instead or
>> reassign Ctrl+Tab in Tools->Options->Keyboard menu
>>
>> --
>> Sergey V. Coox
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"


0

Please sign in to leave a comment.