14 comments
Comment actions Permalink

Hello Joey,

what build of ReSharper you're using?


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

i am experiencing weird context menu using resharper, i have a number
of gotodeclaration menus... see attached pic...



0
Comment actions Permalink

Hello Joey,

does reinstalling ReSharper help to get rid of this problem?

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

1.5.1 sir



0
Comment actions Permalink

it's fixed now sir, thanks!

more power!

one more thing, it's now gone on my context menu, i forgot how i got it there the first time...

0
Comment actions Permalink

Hello Joey,

could you please clarify what do you mean? ReSharper entries should be
in the context menu, they are added there automatically when you activate
ReSharper.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

it's fixed now sir, thanks!

more power!

one more thing, it's now gone on my context menu, i forgot how i got
it there the first time...



0
Comment actions Permalink

i was referring to the gotodeclaration context menu as this post subject suggest. upon reinstalling, i couldn't find the said menu entry, but the others are there (find usage, etc.). now it's back... i hope i don't encounter the redundant yet disabled gotodeclarion context menu entries again...

0
Comment actions Permalink

Hello Joey,

you can also try to run 'devenv.exe /setup' to get rid of such problems.
But be careful:
this will delete all your UI customization (including custom toolbars), though
it is irrelevant
if you don't have them.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

i was referring to the gotodeclaration context menu as this post
subject suggest. upon reinstalling, i couldn't find the said menu
entry, but the others are there (find usage, etc.). now it's back... i
hope i don't encounter the redundant yet disabled gotodeclarion
context menu entries again...



0
Comment actions Permalink

????[/url]
????[/url]
????[/url]
sql server??[/url]
raid????[/url]
sql?????[/url]

0
Comment actions Permalink

Doing a repair install of 1.5.1 does not clear these multiple context menu items for me.

(Also, on one of my projects, but apparently only that one, absolutely no symbols can be resolved, not even "System", even after uninstalling and reinstalling ReSharper.)



Attachment(s):
goto.jpg
0
Comment actions Permalink

Have you tried shutting down VS.Net, and then going through and deleting all
the "_ReSharper*" cache directories, and then reloading? Just an idea.

"Adam Vandenberg" <no_mail@jetbrains.com> wrote in message
news:19058047.1125348559080.JavaMail.javamailuser@localhost...

Doing a repair install of 1.5.1 does not clear these multiple context menu
items for me.

>

(Also, on one of my projects, but apparently only that one, absolutely no
symbols can be resolved, not even "System", even after uninstalling and
reinstalling ReSharper.)



0
Comment actions Permalink

Didn't help; even when I blow away all the caches the usual ReSharper loading dialog only shows onscreen for a split scecond instead of the usual "a while" while it reparses the project.

0
Comment actions Permalink

Alright, got multiple pop-ups under control, though the symbols in that project still aren't resolving.

0
Comment actions Permalink

Hello Adam,

please describe in more detail the project where symbols are not resolved.
What kind of project is it? What assemblies/other projects does it reference?
And what symbols aren't resolved - only those declared externally (in referenced
assemblies/projects)
or all symbols including those declared in that very project?

Thanks.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Alright, got multiple pop-ups under control, though the symbols in
that project still aren't resolving.



0
Comment actions Permalink

In the process of trying to trim my .sln down to small repro case, the bug stopped happening.

If it starts again I'll try to save it and get a specific small set of files that repro.

Thanks,
Adam V.

0

Please sign in to leave a comment.