VS2003 w/ ReSharper 1.5 Coexistence VS2005 w/ ReSharper 2.0

Hello JetBrains,

Since I have read diverging posts about the ability to have
VS2003/ReSharper 1.5 installed in parallel with VS2005
(release)/ReSharper 2.0 EAP (one posting here says it 'should somehow'
work, in the tracker (#7770) there is an explicit denial about that),
I'd like to ask what the status on this was.

VS2003/ReSharper 1.5 is a stable and productive environment, which I
will not lightly abandon to test EAP software. I do test the EAP builds,
and I'm a good boy in reporting issues, still, having a stable coding
environment for day-to-day work is nice ;)

What would be the technical reasons that ReSharper 1.5/2.0 cannot
coexist on the same machine?

Please point me to the appropriate information if this has already been
discussed elsewhere.

Thanks for your consideration,

Christian

Licensed User (yeah)

1 comment
Comment actions Permalink

Hello Christian,

technically there is no any reason why 1.5 and 2.0 for VS 2005 cannot co-exist
on the same machine.
The problem (#7770) you're referring to is that they currently share the
same file with the user settings
(UserSettings.xml), but 2.0 is unable to import settings from 1.5 and 1.5
cannot read newer version
of this file. Aside from this issue, side-by-side installation should work
fine.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello JetBrains,

Since I have read diverging posts about the ability to have
VS2003/ReSharper 1.5 installed in parallel with VS2005
(release)/ReSharper 2.0 EAP (one posting here says it 'should somehow'
work, in the tracker (#7770) there is an explicit denial about that),
I'd like to ask what the status on this was.

VS2003/ReSharper 1.5 is a stable and productive environment, which I
will not lightly abandon to test EAP software. I do test the EAP
builds, and I'm a good boy in reporting issues, still, having a stable
coding environment for day-to-day work is nice ;)

What would be the technical reasons that ReSharper 1.5/2.0 cannot
coexist on the same machine?

Please point me to the appropriate information if this has already
been discussed elsewhere.

Thanks for your consideration,

Christian

Licensed User (yeah)



0

Please sign in to leave a comment.