ResSharper 1.5 Keyboard Shortcuts

I installed a new hard drive in my notebook over the long Thanksgiving weekend and I'm using a regular user account (instead of an administrator account) with Windows XP and Visual Studio .NET 2003. The problem I have is that ReSharper 1.5.1 insists on setting the keyboard shortcuts every time I run Visual Studio. If there some flag in the registry or in the filesystem I need to set to prevent ReSharper from overwriting my custom shortcuts?

I worked around the problem temporarily by saving my customized shortcuts and then marking the .vs. file read-only, but ReSharper keeps complaining that it can't set the keyboard shortcuts every time I start Visual Studio.

3 comments
Comment actions Permalink

Hello Lothan,

ReSharper 1.5 keeps the information about necessity to set keyboard shorcuts
in the registry: HKLM\Software\JetBrains\ReSharper[OneTimeInitializationRequired].
It seems
to me that this value my be inaccessible for writing when you're running
under a non-administrative
account. Please try to reset it manually and check if it helps.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I installed a new hard drive in my notebook over the long Thanksgiving
weekend and I'm using a regular user account (instead of an
administrator account) with Windows XP and Visual Studio .NET 2003.
The problem I have is that ReSharper 1.5.1 insists on setting the
keyboard shortcuts every time I run Visual Studio. If there some flag
in the registry or in the filesystem I need to set to prevent
ReSharper from overwriting my custom shortcuts?

I worked around the problem temporarily by saving my customized
shortcuts and then marking the .vs. file read-only, but ReSharper
keeps complaining that it can't set the keyboard shortcuts every time
I start Visual Studio.



0
Comment actions Permalink

That fixed the problem, but this setting should be stored in HKCU instead of
HKLM since it relates to user-level configuration.

--
Greg Law

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d9c52c68c7c93c256c1d84@news.intellij.net...

Hello Lothan,

>

ReSharper 1.5 keeps the information about necessity to set keyboard
shorcuts
in the registry:
HKLM\Software\JetBrains\ReSharper[OneTimeInitializationRequired]. It seems
to me that this value my be inaccessible for writing when you're running
under a non-administrative
account. Please try to reset it manually and check if it helps.

>
>

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> I installed a new hard drive in my notebook over the long Thanksgiving
>> weekend and I'm using a regular user account (instead of an
>> administrator account) with Windows XP and Visual Studio .NET 2003.
>> The problem I have is that ReSharper 1.5.1 insists on setting the
>> keyboard shortcuts every time I run Visual Studio. If there some flag
>> in the registry or in the filesystem I need to set to prevent
>> ReSharper from overwriting my custom shortcuts?
>>
>> I worked around the problem temporarily by saving my customized
>> shortcuts and then marking the .vs. file read-only, but ReSharper
>> keeps complaining that it can't set the keyboard shortcuts every time
>> I start Visual Studio.
>>
>



0
Comment actions Permalink

Hello Lothan,

you're right, but ReSharper 1.x cannot be installed for the current user
only. We've
fixed this in ReSharper 2.0, where this setting is stored on a per-user basis.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

That fixed the problem, but this setting should be stored in HKCU
instead of HKLM since it relates to user-level configuration.

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d9c52c68c7c93c256c1d84@news.intellij.net...

>> Hello Lothan,
>>
>> ReSharper 1.5 keeps the information about necessity to set keyboard
>> shorcuts
>> in the registry:
>> HKLM\Software\JetBrains\ReSharper[OneTimeInitializationRequired]. It
>> seems
>> to me that this value my be inaccessible for writing when you're
>> running
>> under a non-administrative
>> account. Please try to reset it manually and check if it helps.
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> I installed a new hard drive in my notebook over the long
>>> Thanksgiving weekend and I'm using a regular user account (instead
>>> of an administrator account) with Windows XP and Visual Studio .NET
>>> 2003. The problem I have is that ReSharper 1.5.1 insists on setting
>>> the keyboard shortcuts every time I run Visual Studio. If there some
>>> flag in the registry or in the filesystem I need to set to prevent
>>> ReSharper from overwriting my custom shortcuts?
>>>
>>> I worked around the problem temporarily by saving my customized
>>> shortcuts and then marking the .vs. file read-only, but ReSharper
>>> keeps complaining that it can't set the keyboard shortcuts every
>>> time I start Visual Studio.
>>>


0

Please sign in to leave a comment.