non monotype font + bold constant identifier bug

default setting for constant identifier for resharper is set to a bold font. this is problematic for some fonts like Verdana where the blinking cursor is displayed at the wrong location.

i have tried using bold to other settings using verdana but the problem was not reproduced so there should be some handling with resharper to the reported location of the cursor which is a bug.

5 comments
Comment actions Permalink

i forgot to attach the image where the cursor should have been at the end of the line...



Attachment(s):
enum problem with resharper.png
0
Comment actions Permalink

jokiz wrote:

default setting for constant identifier for resharper is set to a bold font. this is problematic for some fonts like Verdana where the blinking cursor is displayed at the wrong location.

i have tried using bold to other settings using verdana but the problem was not reproduced so there should be some handling with resharper to the reported location of the cursor which is a bug.


I have had the same problem already, though it's not a problem of
ReSharper, but of VS2003. It happens even if you don't have ReSharper
installed.

Maybe it would be better if ReSharper didn't use bold fonts by default.
It took me quite some time to figure out what was wrong..

Here's the tracker entry btw:
http://www.intellij.net/tracker/resharper/viewSCR?publicId=21830

Max

0
Comment actions Permalink

thanks markus.

just like thomas (http://www.intellij.net/tracker/resharper/viewSCR?publicId=983) i still think it is not with VS but with resharper since it functions correctly with resharper unloaded.

0
Comment actions Permalink

i still think it is a bug with resharper

0
Comment actions Permalink

Hello jokiz,

not really. ReSharper neither draws text in the editor nor positions the
caret, it's the VS text editor who does all that. ReSharper only tells
the editor that a particular piece of text should be bold, so the problem
almost definitely has something to do with VS. The workarounds are:

1) Change the font as some fonts don't suffer from this
2) Disable bold for constants.

We'd be really happy to fix this issue but we don't know how to do that.
Moreover, there were rumours that other VS extensions also exhibit it,
which is an additional indication of a VS issue.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

i still think it is a bug with resharper



0

Please sign in to leave a comment.