VS2005, R# 2.0 and Typing Delay, Intellisense, etc..Solution Working for Me

After searching high and low for what might be causing a delay with typing with VS2005 and R# I have stumbled upon a solution that seems to work pretty good for me and thought I would share.

.

1). Turn off the navigation bar. Tools > Options > Text Editor > C# > Uncheck the Navigation Bar. You lose the top two drop downs but Ctrl+F12 in R# is more useful for me.

2). Turn off track changes. Tools > Options > Text Editor > Uncheck Track Changes in the Settings group panel.

Doing these two things has for the first time made R# 2.0 intellisense useful for me and has pretty much gotten rid of all delays in typing and backspacing. Your "mileage may vary" but I hope this at least helps a few people.

5 comments
Comment actions Permalink

Hello Mike,

thanks a lot for this information, it's realy interesting. We're not aware
of the face that those VS options affect the performance of typing with ReSharper
and will check that.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

After searching high and low for what might be causing a delay with
typing with VS2005 and R# I have stumbled upon a solution that seems
to work pretty good for me and thought I would share.

[This information was gathered through combing through the forum here
and the MSDN forums].

1). Turn off the navigation bar. Tools > Options > Text Editor > C#

Uncheck the Navigation Bar. You lose the top two drop downs but

Ctrl+F12 in R# is more useful for me.

2). Turn off track changes. Tools > Options > Text Editor > Uncheck
Track Changes in the Settings group panel.

Doing these two things has for the first time made R# 2.0 intellisense
useful for me and has pretty much gotten rid of all delays in typing
and backspacing. Your "mileage may vary" but I hope this at least
helps a few people.



0
Comment actions Permalink

Well, I need to type slower - 'realy' -> 'really', 'face' -> 'fact' etc

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Mike,

thanks a lot for this information, it's realy interesting. We're not
aware of the face that those VS options affect the performance of
typing with ReSharper and will check that.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>> After searching high and low for what might be causing a delay with
>> typing with VS2005 and R# I have stumbled upon a solution that seems
>> to work pretty good for me and thought I would share.
>>
>> [This information was gathered through combing through the forum here
>> and the MSDN forums].
>>
>> 1). Turn off the navigation bar. Tools > Options > Text Editor > C#
>>
>>> Uncheck the Navigation Bar. You lose the top two drop downs but
>>>
>> Ctrl+F12 in R# is more useful for me.
>>
>> 2). Turn off track changes. Tools > Options > Text Editor > Uncheck
>> Track Changes in the Settings group panel.
>>
>> Doing these two things has for the first time made R# 2.0
>> intellisense useful for me and has pretty much gotten rid of all
>> delays in typing and backspacing. Your "mileage may vary" but I hope
>> this at least helps a few people.
>>


0
Comment actions Permalink

Hi,

Sometimes it also helps to turn off HTML errors in the IDE.
Tools->Options>Text Editor>HTML>Validation.


And turning wordwrap off is reported by some to improve performance.
Tools->Options>Text Editor>C#>General.

/peter

"Mike Anderson" <no_reply@jetbrains.com> wrote in message
news:8123227.1153837198263.JavaMail.itn@is.intellij.net...

After searching high and low for what might be causing a delay with typing
with VS2005 and R# I have stumbled upon a solution that seems to work
pretty good for me and thought I would share.

>

[This information was gathered through combing through the forum here and
the MSDN forums].

>

1). Turn off the navigation bar. Tools > Options > Text Editor > C# >
Uncheck the Navigation Bar. You lose the top two drop downs but Ctrl+F12
in R# is more useful for me.

>

2). Turn off track changes. Tools > Options > Text Editor > Uncheck
Track Changes in the Settings group panel.

>

Doing these two things has for the first time made R# 2.0 intellisense
useful for me and has pretty much gotten rid of all delays in typing and
backspacing. Your "mileage may vary" but I hope this at least helps a few
people.



0
Comment actions Permalink

I just wanted to say that ever since I disabled these options below, my visual
studio instance became much more responsive. This has made a world of difference
for me.

Thanks so much for the tip Mike!

Jetbrains: Have you investigated this at all to understand why it makes such
a huge difference?

Thanks,

~Andy

After searching high and low for what might be causing a delay with
typing with VS2005 and R# I have stumbled upon a solution that seems
to work pretty good for me and thought I would share.

[This information was gathered through combing through the forum here
and the MSDN forums].

1). Turn off the navigation bar. Tools > Options > Text Editor > C#

Uncheck the Navigation Bar. You lose the top two drop downs but

Ctrl+F12 in R# is more useful for me.

2). Turn off track changes. Tools > Options > Text Editor > Uncheck
Track Changes in the Settings group panel.

Doing these two things has for the first time made R# 2.0 intellisense
useful for me and has pretty much gotten rid of all delays in typing
and backspacing. Your "mileage may vary" but I hope this at least
helps a few people.



0
Comment actions Permalink

Hello Andy,

no, we haven't investigated the performance of typing with regard to those
VS options yet. We're going to
do that but, frankly speaking, I don't know what can we do about it even
if we confirm this fact.
ReSharper has nothing to do with those options and it looks like this is
a performance problem of VS editor itself
if the latter is so affected by those options.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I just wanted to say that ever since I disabled these options below,
my visual studio instance became much more responsive. This has made
a world of difference for me.

Thanks so much for the tip Mike!

Jetbrains: Have you investigated this at all to understand why it
makes such a huge difference?

Thanks,

~Andy

>> After searching high and low for what might be causing a delay with
>> typing with VS2005 and R# I have stumbled upon a solution that seems
>> to work pretty good for me and thought I would share.
>>
>> [This information was gathered through combing through the forum here
>> and the MSDN forums].
>>
>> 1). Turn off the navigation bar. Tools > Options > Text Editor > C#
>>
>>> Uncheck the Navigation Bar. You lose the top two drop downs but
>>>
>> Ctrl+F12 in R# is more useful for me.
>>
>> 2). Turn off track changes. Tools > Options > Text Editor > Uncheck
>> Track Changes in the Settings group panel.
>>
>> Doing these two things has for the first time made R# 2.0
>> intellisense useful for me and has pretty much gotten rid of all
>> delays in typing and backspacing. Your "mileage may vary" but I hope
>> this at least helps a few people.
>>


0

Please sign in to leave a comment.