Cannot resolve symbol

Hi,

Just installed Resharper v2 (249) and made a test website in vs2005.

On the Default.aspx page I added a TextBox (TextBox1) and in the code behind
file I just added:

public partial class _Default : Page
{
protected void Page_Load(object sender, EventArgs e)
{
TextBox1.Text = "test";
}
}

The reshaper intellisense worked as expected on TextBox1. and showed a
dropdown list.

Now I added a new WebUserControl to the website, and added a TextBox
(TextBox1) on this too. But now reshaper says that TextBox1 can't be
resolved and show the symbol in red.

public partial class WebUserControl : UserControl
{
protected void Page_Load(object sender, EventArgs e)
{
TextBox1.Text = "test";
}
}

Is this something just on my system or can others reproduce this ?

/peter


11 comments
Comment actions Permalink

Hi peter,
I have the same problem, it seems that Resharper doesn't work correctly with partial classes... If somebody has an answer abt it, would be great.

0
Comment actions Permalink

Hi,

Tested to see if it has anything to do with regional settings, but the
problem is there regardless of I am using Danish or English settings.

The strange thing is that it sometimes help to build and run the site.

It seems like the resharper cache isn't getting updated properly when I add
a new item to the web site. So resharper is not aware of the newly created
TextBox.

/peter

"peter sørensen" <xx.xx@xx.xx> wrote in message
news:e53pgv$ush$1@is.intellij.net...

Hi,

>

Just installed Resharper v2 (249) and made a test website in vs2005.

>

On the Default.aspx page I added a TextBox (TextBox1) and in the code
behind file I just added:

>

public partial class _Default : Page
{
protected void Page_Load(object sender, EventArgs e)
{
TextBox1.Text = "test";
}
}

>

The reshaper intellisense worked as expected on TextBox1. and showed a
dropdown list.

>

Now I added a new WebUserControl to the website, and added a TextBox
(TextBox1) on this too. But now reshaper says that TextBox1 can't be
resolved and show the symbol in red.

>

public partial class WebUserControl : UserControl
{
protected void Page_Load(object sender, EventArgs e)
{
TextBox1.Text = "test";
}
}

>

Is this something just on my system or can others reproduce this ?

>

/peter



0
Comment actions Permalink

Jordi,

The most likely ReSharper does not catch file changes, made via visual
designer. What happens if You alter source code in an HTML view?
--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Hi,

Yes, it seems like resharper only is triggered on changes in the HTML editor
and not in the visual designer !

/peter

"Sergey V. Coox (JetBrains)" <qx@intellij.com> wrote in message
news:e53u5v$j5f$1@is.intellij.net...

Jordi,

>

The most likely ReSharper does not catch file changes, made via visual
designer. What happens if You alter source code in an HTML view?
--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"



0
Comment actions Permalink

Hi,

I have a web site where resharper refuses to resolve some TextBox
references. Editing the HTML file here does not solve this, but in a new web
site solution it seems enought to add a newline in the HTML editor for
getting resharper to resolve symbols.

/peter

"Sergey V. Coox (JetBrains)" <qx@intellij.com> wrote in message
news:e53u5v$j5f$1@is.intellij.net...

Jordi,

>

The most likely ReSharper does not catch file changes, made via visual
designer. What happens if You alter source code in an HTML view?
--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"



0
Comment actions Permalink

Peter,

I've got exactly the same complaint from one of our users. Could You do the
following, please: go to ReSharper->Options->Clear caches and reopen the
solution. It might help.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Peter,

What VS version do You use? Unfortunately, the event from VS designer is not
always got by R#, and editing of the source assures synchronization with the
file text.
--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Hi,

Tried this and it doesn't help.

But try to see my new post "Found error in scanning of asp files", this
might help you to find the error.

/peter

"Sergey V. Coox (JetBrains)" <qx@intellij.com> wrote in message
news:e547oo$q6f$1@is.intellij.net...

Peter,

>

I've got exactly the same complaint from one of our users. Could You do
the following, please: go to ReSharper->Options->Clear caches and reopen
the solution. It might help.

>

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"



0
Comment actions Permalink

Hi,

I am using the VS2005 professional version, with the hotfix the resharper
installer suggested to install.

It is installed on a English windows XP professional, with the latest SP's

/peter

"Sergey V. Coox (JetBrains)" <qx@intellij.com> wrote in message
news:e547tm$qna$1@is.intellij.net...

Peter,

>

What VS version do You use? Unfortunately, the event from VS designer is
not always got by R#, and editing of the source assures synchronization
with the file text.
--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"



0
Comment actions Permalink

Peter,
I've already answered. Thanks a lot.
--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

did you ever figure the issue and resolve it?

0

Please sign in to leave a comment.